On Mac 'View' menu, keyboard shortcuts for 'Navigate Back' and 'Navigate Forward' are incorrect

on Mac on the ‘View’ menu, the keyboard shortcuts that appear next to the ‘Navigate back’ and ‘Navigate forward’ menu commands are incorrect.

Currently in build 0.8.14, the shortcuts that appear next to the two commands are ‘⌘ ←’ and ‘⌘ →’ respectively. The correct keyboard shortcuts for ‘Navigate back’ and ‘Navigate forward’ are ‘⌥ ⌘ ←’ and ‘⌥ ⌘ →’

Steps to Reproduce:

  • install Obsidian on a Mac
  • launch Obsidian
  • open the help
  • command-click on some of the links to follow them
  • type ‘⌘ ←’ keys (command + left arrow)

Expected Result:

  • Obsidian should navigate back to the previous page

Actual Result:

  • nothing happens
  • you need to type ‘⌥ ⌘ ←’ keys (option + command + left arrow) to go back

Environment

  • Operating system: macOS Catalina 10.15.6
  • Obsidian version: 0.8.14

Additional information

4 Likes

yes, please. let’s fix this is very annoying (i was about to report a bug!)
(still on 0.10.1)

I experienced this and also thought it was a bug. I don’t think it is a bug.

If you are in preview mode then the command arrows keys work as expected.
If you are in edit mode then the command arrow keys go to the beginning/end of the line I am on. Seems this is overriding the note navigation

Going from a note in preview mode to one in edit will only let the command work the first time then not anymore.

just a noodge of a comment: unexplained differences in key-command behavior based on pane being viewed is what I’d call a bug (unless it is actually described & explained somewhere)… :^)

I just wanna add, certain hotkey on windows might be an issue.

I’m on the latest windows version of 0.14.6, the shortcut/hotkey for navigation doesn’t work mapped on Ctrl + Alt + ->/<-, but clicking the icon or using command palette works.

I tried the “reading view” but it has no effect. I am guessing this is because an issues with default OS setting Ctrl + Alt + arrow for display orientation. This is still present despite turning off the windows’ shortcut. So other window users should avoid this combination