Obsidian's Resolution EXTREMELY High Compared to Monitor Resolution

Hi all,

Obsidian seems to have switched to a much higher resolution than everything else on my OS. My screen resolution is 2048x1152 but Obsidian looks like it’s running at 3840x2160, the maximum my screen is capable of! I can barely read the text!

I’m new to both Linux and Obsidian so I’m not sure if I’ve accidentally switched a setting somewhere that I wasn’t supposed to. But it just seemed curious that Obsidian and only Obsidian is running at that resolution. Has anyone else experienced this before?

I’m running Obsidian v0.12.19 (at least I think that’s what it says) via AppImage with the default themes and plugins on the following machine:

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.10.79-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × 11th Gen Intel® Core™ i7-1185G7 @ 3.00GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics

Any and all help would be very much appreciated!

Just checking, is there a chance you zoomed the text? I know there is a pinch-and-zoom gesture I keep accidentally hitting on my trackpad that shrinks the text. And that setting is separate from the View → Zoom settings, so I don’t know of any way to reset it by keyboard.

The other thing to check is if you did activate View → Zoom Out, because that also scales the text and the entire interface. Ctrl+= and Ctrl+-. To reset the view, it should be Ctrl-0.

Otherwise, the only similar threads I can remember were on MacOS. One user had checked “Open in Low Resolution” in the app settings. (Opposite problem. Everything got low res and blurry, not small. But that is a MacOS thing only I believe.)

And if it is none of that, could you please post a screenshot?

Thanks for the reply!

Yes, I came across that MacOS thread while searching but it didn’t seem relevant.

And, for the sake of clarity, it wasn’t only the font size that had shrunk (e.g. in the editor/preview panes), it was the entire interface (i.e. menus, icons, status bar, etc). So, that being the case, your Ctrl+0 suggestion fixed everything! THANK YOU!

Absolutely NO idea how I managed that considering how many times I had to press Ctrl+- just to replicate the problem! I also can’t seem to find those settings in the list of hotkeys or the command palette. Is that more of a general electron thing? I noticed I can replicate it with VS Code too.

I’ll leave a couple of screenshots just in case any other newbies are having the same issue and need a visual. (I apologise in advance for my bright screens, but my office is very, very sunny!)

Thanks again!


Reset with Ctrl+0:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.