Obsidian won't start on a new install of Arch Linux

Things I have tried

Version 0.12.15

I have tried the obsidian package, and the obsidian-appimage package from the AUR. The start up message is the same:

 Loading main app package /usr/lib/obsidian/obsidian.asar
No protocol specified
The futex facility returned an unexpected error code.
Aborted (core dumped)

What I’m trying to do

start obsidian

we only handle bug reports for the official installers here Download - Obsidian

The issue isn’t with the installation it seems to be a config or runtime error. Both these packages in the aur simply download either the source from github, or the appimage from the link you provided.

Any help in getting more verbose info would be appreciated. Closing this isn’t going to solve the issue and other people will open new tickets…

Ok, I am going to move this back to help.

Hi,

I’m experiencing the same problem with the Obsidian AppImage from the official website:

2021-10-10 22:36:12 Loading main app package /tmp/.mount_Obsidi1t6uID/resources/obsidian.asar
The futex facility returned an unexpected error code.

OS: Manjaro LInux
DE/WM: Sway
Obsidian version: 0.12.15