Obsidian will not open after download (Mac i5)

Okay, so Im new to Obsidian and Ive only just tried downloading it on my i5 Intel MacBook, but it just won’t open at all. Ive tried deleting and downloading the Mac client again yet it just won’t open, only remaining as dmg file. Not much help from online about it too, so I’m stuck. Any help would be appreciated.

What macOS version are you using?

Your macOS version may not be compatable with the latest installer.

The current and previous versions are here:

https://github.com/obsidianmd/obsidian-releases/releases

MacOS 14.3.1 (23D60)

Tried downloading a couple older MacOS versions to the same response. I’ll just wait and try again later today to see if there are any improvements.

Obsidian v1.5.8+ requires macOS 10.15 or later.

Try the v1.5.3 installer:

https://github.com/obsidianmd/obsidian-releases/releases/tag/v1.5.3

Obsidian-1.5.3-universal.dmg

Same thing with this version. Not at all sure what the issue is, but it’s most likely on my end. I’ll wait and see if there are any changes in a couple hours.

Updated my MacBook and now the download is working perfectly.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.