Obsidian v1.4.10+ and Obsidian Sync: CSS changes are being reverted by unnecessary downloads from Obsidian Sync

The Issue:

Sometime in the week of September 11th, I started noticing edits I made to .css files in my vaults were reverting after two changes made closely in time to one another. An auto-undo of sorts. I originally thought Obsidian Sync was having a timing or a possible network issue, but after some experimenting it seems the behavior started with a change between Obsidian v1.4.9 and v.1.4.10 while using Obsidian Sync.

Steps to reproduce

  • Obsidian v1.4.13 (1.4.13 installer)
  • Restricted mode on (with a restart)
  • Default theme
  • Obsidian Sync active and Themes and snippets sync toggled ON.
  1. Make an edit to a .css file. Observe the visual change in Obsidian and Sync uploading the file.
  2. Make another change in the same .css file. Observe the visual change and Sync upload, but immediate download overwriting the second change.

Did you follow the troubleshooting guide?

Yes, with Obsidian Sync running and one snippet enabled.

Expected result

Making a change to a .css file without it immediately downloading an older version and reverting the changes as demonstrated here using Obsidian v1.4.5 (v1.4.5 installer). v1.4.9 also functions this way.

Actual result

Making a CSS change and then another shortly thereafter, the second change is being reverted by an unnecessary download from Obsidian Sync using Obsidian v1.4.13.

Additional information

  • If sync is paused, there is no issue.
  • Only one device is turned on and being used when this happens.
  • The issue exists on multiple desktop devices (Mac and Windows) and with multiple Obsidian Synced vaults. The system time on both devices is correct.
  • Using Obsidian Sync since Aug 2021 and have never experienced this before. I play with CSS a lot.
  • Again, using Obsidian Sync with up to Obsidian 1.4.9 (1.4.5 installer) doesn’t exhibit this issue. This behavior is from Obsidian v1.4.10 onward.
  • Originally brought up in the #obsidian-sync Discord channel.


Screen recordings are from a MacBookPro / M1Pro / macOS 13.5.2

	Obsidian version: v1.4.13
	Installer version: v1.4.13
	Operating system: Darwin Kernel Version 22.6.0: Wed Jul  5 22:22:05 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6000 22.6.0
	Login status: logged in
	Catalyst license: supporter
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: none
	Snippets enabled: 1
	Restricted mode: on

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.


Thank you very much for this issue report. I’ve successfully managed to reproduce the issue and we’re investigating a fix.


We believe this issue is closely related with this one as well.

We think we’ve identified the issue and are working on a fix now. Thanks for your patience!


This issue seems fixed with Obsidian 1.4.14, but I’ll keep testing and let the team mark it as solved when they see fit.

Thanks all.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.