Obsidian Utilities v2

Hi!

A new version of my Alfred workflow is now up on Github. You can also download it directly by clicking this link.

What’s new

  • There’s a new Global Search feature that searches all your vault and automatically inserts links to found notes, headers or blocks.
  • The clip action now works with Google Chrome. (Thanks for the AppleScript, @alvaroybanez!) Don’t forget to change the default_browser environment variable if you want to use that instead of Safari.

What’s changed

  • The worklow does not assume the vault is inside your home folder anymore. vault_path must now be a full, absolute path.

If you decide to take it for a spin, let me know how it goes.

Cheers!

6 Likes

Great workflow! Very sweet setup and handy – thanks for this! I was using your older version and am delighted to see you’ve added Global Search & Linking. Have given it a spin and found it working well (the “s” function had a leftover reference under “scope” to what must come from your local setup – after removing it [a dropbox path] it worked beautifully.)
The “clip” function creates an entry with a link to the the webpage and places a link into my daily notes. (If I understand you correctly the idea is to produce a markdown version of the current webpage in Safari.) Appreciated your documentation and even managed to tweak some of the headings thanks to your generous description. I will be using this a lot!

1 Like

Awesome! Thank you very much for your feedback. I’ll fix the scope soon.

As for the clip action: does it merely place a link on the created note? It was indeed supposed to convert the webpage to markdown. :face_with_monocle:

Yep. A get new .md-note with the website’s title and a weblink inside. (And I also get a wiki-link entry appended to this note in my daily notes). I’ve used the clip function in your previous workflow and recall it working well.
What would I need to do to get it to work with Typora rather than with VS Code?

@macedotavares the global search is fantastic. Kudos on this new version!

Let’s keep in touch for more features, I’ve got a couple of ideas… :wink:

1 Like

I’m so glad you like it! Let me hear your ideas!

There was something wrong with a dependency. I’ll push the fix tomorrow.

If you double-click on the “Open file” module, you can change the external editor to whatever you want. Then, the easiest way to do it is to invoke Alfred, search for the app and drag it from the results into the module.

I’m on windows. None of this is useable for me, is that right?

I’m afraid so.

I’ve seen someone compare Power Toys to Alfred recently, so if you haven’t tried it yet, maybe you should take a look.

1 Like

@Marc-A, v2.0.1 is now available here.

  • Fixed hardcoded scope in search.
  • Fixed markdown clipping.

Or so I hope :woozy_face:

Again, thanks for the feedback. Let me know if something’s still wrong.

Cheers!

1 Like

Great. Gave it a brief spin – all is working well and as described! Thanks for the speedy fix - this is really useful and productive now.

I even tried tweaking it to run with Opera Beta (instead of Safari or Chrome) but so far to no avail. (I got stumped with the log entry 0curl: (6) Could not resolve host: favorites).

@WahWah: You may have a look at AutoHotkey I used it many years ago when still on Windows.

1 Like

Great to hear that! :beers:
Apparently, Opera is returning an invalid URL, favorites. Do you have a favorites tab open?