Obsidian third-party plugins not downloading

Things I have tried

What I’m trying to do

Hi! I recently tried to download third-party plugins for the first time, but every time I try to download it via Obsidian, it tells me “failed to install (name of plugin)”. I’m not sure why it doesn’t work…

I live in North America, so I don’t think it’s a firewall issue.

Thank you in advance!

Does it happen to all plugins or only some?

All third-party plugins, yes. Just tried to download the top 10 and it didn’t work.

Can you access https://raw.githubusercontent.com/obsidianmd/obsidian-releases/master/community-plugins.json?

Yes, I can.

I’m out of ideas then, hope someone can help you!

Might help to check for console errors too:

To check for errors, first open the developer tools by pressing Ctrl-Shift-I on Windows/Linux or Cmd-Opt-I on macOS, and then go to the “Console” tab. If you want to save the error to a log file, you can right click on the error and choose “Save as…”.

Alright, I’ll take a look at that! Thank you for your help!

This appears when I try to download plugins, I’m not sure where I would need to save the error. I’m not super tech-savvy when it comes to things like this, oops.

In Settings - About, is your installer version low? Latest is at 0.11.5 now. Try downloading from obsidian.md again.

It works now! Can’t believe I didn’t think to update Obsidian, thank you!

1 Like