Obsidian Sync seems to delete files?

Is there any new insight on the deleted files? I am having the same problem. Files mysteriously deleted. I am using Obsidian sync. I have started using sync 6 days ago - the first deleted file is from 5 days ago. I am using a number of plugins.
I have just discovered this issue and have only tried to recover one file so far: With this the recovery worked in so far that the note as such reappeared, but in a separate entry. I now have two notes with the same title - at least in my search; but I think also actual. The link pointing to the formerly deleted file is now signalling that there is an existing file for this link (dark blue in my case). But when I click on the link I am directed to the empty note (as before the recovery). I can, however, access the recovered note - e.g. via the search.
This is pretty scary for me - it would obviously be great to find a solution here. I am going to start recovering my files and hope that I can recover all of them.
I am syncing one vault from a Windows PC to another Windows PC and two mobile devices (iPhone, iPad). Don’t know if this is of any relevance.

Further to my post:
The largest portion of deletions seems to be connected to my activity of 3 days ago when I moved a large number of my notes into different folders - using the system explorer since moving several files at once is not possible in Obsidian. But there are also deletions before and after that which I can not place in that context. I am pretty sure that Obsidian has “noticed” the moved notes correctly and I am pretty sure that I could link to the moved files without a problem everywhere I did that - the autocomplete showing me the whole file path of where the file now is located.

When I try to reconnect the link with the (deleted and recovered) note, autocomplete shows me the single (empty) file in the original (“home”) location and the (apparently) recovered file in the location / path I had moved the file to. When I connect the file in the new location the link is then showing the path and the filename (“folder/notetitle.md”) which it previously had not.

Sorry about the lengthy description of the problem. Maybe some of the details are useful for understanding the issue. Happy to learn if there are certain things I shouldn’t be doing with the files.

2nd update:
This is going to take a while to repair … there are roughly 800 deleted files and I have to reconnect (or copy to clipboard and paste) for every single one … (or maybe I should go to system trash and move the files from there into the system explorer - it’s probably superstitious but after what happened after my last system explorer operation I am not sure if that is a good idea)

3rd update:
They are not there in the system trash … hoping the best for my recovery. Actually this is not what I expected when I decided to pay for sync. I love Obsidian but this is my first setback.

It’s me again. Another strange thing that I discovered: A file that I created, that was deleted, then automatically recreated and deleted again …
image

Or this - I have the feeling it has something to do with syncing to mobile beta version. As I was pretty actively playing around with my iPhone and iPad versions.

@kennydenvers since this is related to mobile I suggest you open a new thread in the mobile category or talke about it on discord on #mobile. I am sorry you expirienced data losses but you were asked to keep backups duing alpha phase of mobile.

From what you describe it sounds like you have 2 files with the same name, one is empty and one is full. Assuming you are using standard wikilinks, if you delete the empty file, the link will not point to the file that has the content.

@WhiteNoise Thanks for your reply! Actually I am not sure if this is connected to mobile - but it seems to be connected to sync. But I lack the knowlegde to even be sure of that (but the whole “deleted files” section is under “sync”).
Also when the issue occurs when I move notes to folders on my original Obsidian system - do you think this is connected with mobile? (“Mobile” not finding the file in the original place and then deleting the “note name” wherever it may find it?)

About backups: Yeah, I know. This is not so much a complaint as it is a description of the issue. Chances are I am not the only person affected by this.

About your remark to the “2 files with the same name”: I am not sure if I understand what you are saying - is the last sentence actually a question? But I have to look into this further with more time.
Currently I have the problem that restoring large PDF files does not seem to work; the system apparently working hard just to switch to the “to be restored” version but continuing to hang there.

Apologies if I am not an experienced user of this forum (or others). If there is a better way to approach this I’d be grateful for some moderating guidance.

It is possible in Obsidian Desktop since a couple of versions ago - Shift+Click (to select in between) or Alt+Click (to select individual files).

There was indeed a bug on our mobile beta that’s not playing well with entire folder moves. The fix came out on v0.0.12.

1 Like

@Licat Great, thanks for your reply and for your amazing work! Hope the (file deletion) issue will be solved through that fix. (Also good to know about the Alt+Click moving option - EDIT: “Alt+Click” does select several files - but only one of the selected files is actually moved apparently)

1 Like

@Licat UPDATE - the deletion issue persists. Just this morning another file was deleted that I hadn’t touched recently. It was located in a folder (if that should be relevant).

Do you have any other sync service setup, like iCloud? We got a report today of this issue that were found to be caused by iCloud.

@Licat No, only Obsidian sync. But I will observe further and update if I can track a certain behaviour.

1 Like

Got it. Would also help if you can keep an eye for the possibility of a plugin causing this.

@Licat One question - maybe you can just confirm. Apparently every file that is moved into another folder or has the “title” changed is presented as deleted. Is this correct from your view?
While I would get the logic behind this, it does lead to some confusion and distraction from “real” deletion issues. Maybe it would be possible to indicate a difference when a file was actually “deleted”.

Ah yes, you mean renamed files.

Unfortunately from the point of view of Obsidian, since files are tracked on a per-path basis, a rename is basically delete + create. If you did it from the OS file explorer, we’d never know the difference.

What we could do in the future is to attempt to track renames, store the rename action in a database so that sync, etc, can keep track of files across renames. Such a system could be even more tedious because Sync is end-to-end encrypted, and our server does not know about your file names (they are encrypted), so keeping track of renames will require additional code to be put in place.

As the one who started this thread I recently encountered another strange bug and maybe someone could make an educated guess on where to look for troubleshooting… (the auto-deleting bug could‘ve been resolved btw by not using an icloud directory): Sometimes, if I create an empty file it gets auto-filled, always with the same content (always the text of one specific file). Any ideas? It looks to me like some sort of template plugin bug of sorts…? Does anyone has an idea on what might cause this strange behavior?

Hi all. All of my hundreds of notes have disappeared after the update to Big Sur. Do you have any idea where to find the notes?

Does this have anything to do with obsidian sync or obsidian at all or this is mac issue?

I haven’t obsidian sync. Could be a Mac issue. Do you think there is any possibility to find the lost notes?

Hi @BjornFred This thread is about Obsidian Sync.

If you want help with your missing files, you would have to provide more information. I suggest you start a new thread in the Help category. And provide all the information you can think of.

  • Your Obsidian version number.
  • The exact path to your vault.
  • A list of any community plugins you were (are) using.
  • Perhaps a screenshot of what you mean by “notes have disappeared” so it is very clear. Are they missing from your vault? Is the vault missing from your list of vaults? Are the files on your hard drive missing? Try to be specific.
  • Feel free to @ me in that new thread so I don’t miss it.

Multiple deleted files noted on two occasions possibly related to change of directory name in Obsidian UI.

Do I need a new report?

Setup:
I am running Sync. Icloud vault with Mini and Macbook Pro 2019.

Obsidian 0.11.7
Catalina 10.15.7 PB, Catalina Mini
several common plugins.

Seems to not like change directory name. Lost multiple files. Restored easily via Sync deleted files log. Happened twice. Not sure what caused it as only rename directory once.

if it happens again, open a new issue and attach the sync log.