Obsidian Sync on iOS downloads new files, but they do not appear in vault

Things I have tried

  • Closing and opening vault
  • Manually re-syncing (jk, doesn’t seem to be possible)
  • Closing and reopening app
  • Logging into and out of sync account
  • Disconnecting and reconnecting vault

I contacted support but they wanted me to create a Discord account (which doesn’t work in Safari, by the way). Apparently email isn’t good enough.

Please, please, please someone from Obsidian tell me if this is a known issue or if I will have to manually uninstall and reinstall Obsidian on mobile every month. I paid for this service (at a premium price point) and I cannot trust it to work.

But based on the sync log showing the files I expect being downloaded, I think there is a bug in the app not showing new folders/files that were pulled down via sync.

I structure my notes by date, so I end up creating new subfolders every month.

What I’m trying to do

  • Use Obsidian Sync for the intended purpose (syncing notes from my computer to my iPad and iPhone)

OK, take 10 deep breaths.

I’m not from Obsidian, but I use Sync on iOS and haven’t seen the behavior you describe, or seen any mentions of it in recent forum or Discord posts that I recall.

Can you see the missing files in the Files app (On my iPhone > Obsidian)? If so, how are you trying to view the files in Obsidian? In the side pane file explorer? Are you using the default file explorer or a plugin replacement? Do they appear in suggestions when you start a link or use Quick Open?

Are the files notes (.md) or some other kind? If some other kind, see Settings > Files & Links > “Detect all file extensions” and the various items under Settings > Sync > “Selective sync”.

Have you used Settings > Files & Links > “Excluded files” and forgotten (unlikely, but possible)?

Can you post the results of the command “Show debug info”?

If you’re using any community plugins, does enabling Settings > Community Plugins > “Restricted mode” and then restarting Obsidian help?

I’ve used Discord in Safari. Do you have JavaScript turned off, or a plugin that might be interfering?

There’s also the traditional cure-all of rebooting your device, if it comes to that.

To add:

We mentioned Discord because:

Debugging it over chat might be easier than over email.

Especially since this issue probably requires a lot of back and forth to debug.
It is not a requirement to use Discord, we can go over this via email if you prefer.

It has been difficult to debug, every time I’m about to give up my notes suddenly appear.

The missing notes show up in the sync activity log, but they do not appear in either Obsidian’s file explorer or the iOS Files app until some mysterious amount of time later. Probably at least 20 minutes (and the app has to be running the whole time), because it took me at least that amount of time to get frustrated enough to set up an Obsidian forums account.

The notes I care about are the .md files - I am familiar with the settings for exclusions and the various options for sync settings.

I sent follow up support emails a few days ago but I never heard back.

Debug info from iPhone:

Operating system: ios 16.0 (Apple iPhone)
Obsidian version: 1.3.2 (69)
API version: v0.15.9
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: California Coast
Snippets enabled: 1
Restricted mode: off
Plugins installed: 13
Plugins enabled: 1
1: System Dark Mode v1.1.0

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

P.S. I felt bad about not having Catalyst so I upgraded just now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.