Obsidian sync doesn't sync plugins

I’m having a synchronisation problem with obsidian sync and I haven’t managed to find a topic on it. I’d like to know if it could be a bug that I need to report or if it comes from a configuration or plugin.

What I’m trying to do

I’ve been using obsidian sync for a few weeks between 2 computers and a smartphone, and I use many community plugins (40). I had configured everything to sync between all devices except appearance settings. Since a few days, my plugins don’t sync anymore and I have to manually install or uninstall them on the other devices if I did it on one. My plugin settings are no longer synchronized either.

Things I have tried

I’ve tried creating a new test vault with just one plugin that I’ve synchronized on 2 devices, the plugin syncs fine. I wonder if this isn’t due to the number of plugins I’m using.

I put the list of plugins in my vault:

  • Advanced Tables
  • Advanced URI
  • Auto Note Mover
  • Code Block Enhancer
  • Commander
  • Dataview
  • Editing Toolbar
  • ExcaliBrain
  • Excalidraw
  • Extract PDF Annotations
  • Global Hotkeys
  • Google Calendar
  • Handwritten Notes
  • Heatmap Calendar
  • Hider
  • List Callouts
  • Local REST API
  • Metadata Menu
  • Natural Language Dates
  • Number Headings
  • Obsidian Charts
  • Obsidian Columns
  • Obsidian42 - BRAT
  • Outliner
  • Paste image rename
  • Plugin Groups
  • Query Control
  • QuickAdd
  • Raindrop Highlights
  • ReadItLater
  • Scroll Offset
  • Spaced Repetition
  • Style Settings
  • Table Enhancer
  • Tasks
  • Templater
  • Text expand
  • Tray
1 Like

The number of plugins shouldn’t matter. When plugin settings are pulled in thru Sync, they don’t take effect until Obsidian restarts (maybe that’s not the problem since it apparently didn’t trip you up before and isn’t tripping you up in the test vault).

Are the Sync settings set correctly in every device?

Thanks for your response.
Yes, I Enable synchronization of all parameters, including plugins, on each of the 3 devices.
It could be due to the fact that you have to restart, but even by restarting obsidian, the plugins are still not synchronized, And it’s never really bothered me so far.

Do you mean the plugin settings aren’t synchronized, or the list of installed/activated plugins isn’t synchronized, or both?

This is the both, the list of install plugins is not synchronise, and also the parameters of the almost all the plugins.

Sorry, I see you said that in the original post. :see_no_evil:

I don’t know why this is happening. Hopefully someone with more insight will comment.

1 Like


I’m experiencing similar problems with Obsidian Sync and plugins / plugin settings. I’m not sure if it’s the same issue because for me it happens from the beginning when setting up a vault, but it could be related.

I have a vault that I’m using on a desktop client and on my iPhone, both are configured to synchronize all of the configuration (including community plugins).

After setting up the vault on a second desktop client and enabling the synchronization options, it did synchronize some files from .obsidian, but not all of them. It also installed all of my community plugins, but it didn’t enable them. In fact, in the synchronization log I can see that .obsidian/community-plugins.json was completely removed in the remote vault, and then recreated, containing only an empty list.

After restoring community-plugins.json and restarting Obsidian, the plugins were enabled, but it still didn’t synchronize the plugin settings.

This also is not the first time I had that problem. Recently I’ve created another vault (on a desktop client), set up Sync, installed and configured some plugins and then tried to set up the vault on my iPhone (so in this case, the other direction: desktop first, then iPhone). Again, it didn’t sync the settings at first, and after getting it to sync them it started deleting files in the remote vault’s .obsidian folder (namely it deleted the entire icon set I’ve installed for the Icon Folder plugin, so I had to reupload them again).

I’m not sure what causes this problem, it feels to me like enabling the settings synchronization on a new device (sometimes?) causes the client to sync its own settings (that haven’t been changed from the defaults yet) to the remote vault instead of syncing the settings from the remote vault to the local vault first.

I also think that it would be good if you could enable the various synchronization options (file types, settings, etc.) directly when setting up Obsidian Sync in the first place, instead of having to enable it afterwards. This might not really be a solution for the syncing problems (which probably are caused by some race condition?), but it certainly would improve the UX and maybe reduce the chance of such issues to occur.

So, are there any known problems with plugin syncing? Or is there something I might be doing wrong?

If there’s anything I can do to help debugging this issue, please let me know. I can also turn this into an actual bug report and try to properly reproduce the issue - I just searched the forum for similar issues and found this thread, so I thought it might be best to comment instead of opening a new one.

Thanks in advance!

I don’t know about everything else, but I do know that someone else mentioned Icon Folder in a thread recently. Icons keep disappearing after sync and restart - #3 by ariehen

1 Like

Icon Folder has a known problem with Sync — check its description for a link to the workaround.

That would be good. (I thought this was already possible but I see now that it’s not.) Improvements to Sync setup are on the roadmap, so maybe it will be possible then. In the meantime it would be a good feature request (one might already exist).

Thanks for the hint about Icon Folder! However, as far as I understand it, the workaround actually disables syncing of the icons deliberately, in order to prevent Sync from being clogged up by too many files. The times when the plugin sync was working, I just had to wait several minutes for all the icons to be copied, after that it worked fine. I don’t mind waiting if it’s just for the initial setup of a vault on a new device.

Do you think the problem of files being not synced at all (or even be outright deleted) is still connected to the amount of files from Icon Folders? Because it wasn’t just the icons that were affected, the list of enabled community plugins and some other settings were also affected.

That’s very nice to hear! :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.