Obsidian sync deletes files created in new folders

Steps to reproduce

Creating a note by specifying a link and clicking on it (e.g. [[obsidian/new folder/new note]] performs the expected behavior and appears to create both the new folder and the note within it. You can then add content to this note and the note will persist. However, when I then open obsidian on another device (which shares the vault via obsidian sync), the device invisibly deletes this note and the folder it resides in. This is mitigated by manually creating the folder first.

Expected result

It seems consistent with the overall UX that creating a new note in a new folder via the specification of a link and following the link should work. The note and folder should persist through syncing.
If this is not intended to work, it should not appear to work and then result in notes being deleted later…

Actual result

Notes and folders are deleted without warning to the user. When the user subsequently attempts to find the note either by following the link or by browsing, they are not present.
(content can, however, be recovered by using obsidian sync’s recovery feature.)


  • Operating system: Windows 10 and IOS.
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.19044
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Things
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 7
    Plugins enabled: 6
    1: Calendar v1.5.10
    2: Citations v0.4.5
    3: Periodic Notes v0.0.17
    4: Dataview v0.5.55
    5: Tasks v1.24.0
    6: Omnisearch v1.11.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

4 posts were merged into an existing topic: Sync does not handle Case Differences in Path/Filename (Rename deleting files during sync)

you have a variation of this problem