Obsidian Sync: Connecting to remove vault failing on iOS in lockdown mode

Steps to reproduce

  1. Install Obsidian from the App store
  2. Set up Sync - enter username and password
  3. See the remote vault - choose to connect to it
  4. See the toast notification “Successfully verified your password”
  5. Get a red error message (with white text) reading: "null is not an object (evaluating ‘this.db.put’)

iPhone 12 Pro; iOS 16.4 Beta, Lockdown mode enabled, over 35 GB storage available on the device (vault is 77 MB).

I purchased Obsidian Sync late Jan but have never successfully connected Obsidian iOS to the Obsidian sync. Sync is working fine between Windows/Mac.

1 Like

Can you post a screenshot of your sync logs
on iOS?

How many remote vaults do you have?

Also, try to uninstall and reinstall the app. Also try with lockdown mode disabled.

It is possible to add add apps to the exclusion list for Lockdown Mode. Perhaps try that and report back on if it makes a difference?

See the section “How to exclude apps or websites from Lockdown Mode”:

I tried deleting and reinstalling the app without any change to behaviour.

Having checked the Sync log after receiving the null is not an object error it does appear to be syncing - I can see it downloading a big pile of files, all the way up to fully synced (there are no errors). However, when I close/restart the app and open the Sync settings, it says it is not connected to any remote vault.

I have two remote vaults in total.

Obsidian doesn’t appear in the list of apps for which you can disable lockdown mode, so I haven’t checked this yet - I’ll take another look over the weekend and see if lockdown mode makes a difference.

FYI we had another user with Lockdown Mode enabled report issues via the support email; they were able to resolve it by adding Obsidian to the exclusion list. (I’m not sure how that’s done, exactly, but at least we have n = 1 for a potential solution here.

Same issue here & same steps as above.
iPhone 14 Pro, Latest iOS Version, Lockdown Mode enabled

null is not an object (evaluating ‘this.db.put’

Can’t add Obsidian to the exclusion list as the list doesn’t contain Obsidian.

Weird. Have you rebooted the phone?

Yes, I’ve already tried rebooting the phone, but to no avail. I would urge you to try replicating the steps mentioned above yourself, as this issue is not unique to me.

Quite a few individuals in the Obsidian Discord community are experiencing the same problem.

The only workaround we have found so far involves completely disabling Lockdown Mode, syncing, and then re-enabling it, which is far from ideal. This process necessitates a restart and disrupts our workflow significantly.

Obsidian Sync is a paid service and currently, it’s not functioning for those who use Lockdown Mode.

I trust in your team to fix this :pray:

This is understandably frustrating, but it seems to be an iOS bug. You should be able to find all of your apps in Lockdown Mode’s exclusion list.

Other users on the web report the same: Reddit - Dive into anything

It is best to report it to Apple. Here’s how to submit feedback to Apple re: iOS: https://www.apple.com/feedback/iphone/​
​I’ll ask the technical team to submit one to Apple on the developer side.

I appreciate your suggestion, but isn’t it possible for the app to operate normally in Lockdown Mode like many other apps do?

Further, from my understanding, Apple will not consider this a bug that needs fixing. Typically, apps only appear in the exclusion list if they open an in-app Safari browser, which Obsidian doesn’t. So, it might not be an issue they will address. Can you help clarify this?

Obsidian sync needs network access. Obsidian is also using safari html rendering engine on iOS.

1 Like

To help others facing the same issue: I also ran into issues with Obsidian Sync in Lockdown mode. The solution was to exclude the app in Lockdown settings.

For Obsidian developers: it would be helpful if you could add a message to people using Lockdown mode AND sync to add the app in the exclusion list in Lockdown settings. You can detect lockdown mode by checking if a particular javascript function fails (which is why Obsidian sync fails). Or even better decrypt the vault without javascript, which might make the sync work in Lockdown mode.

1 Like

Obsidian does not appear in the “exclusion list” unfortunately

The decryption of the vault without javascript makes a lot of sense and would potentially fix the issue.

I am not sure we can detect lockdown mode simply by detecting network calls fail. They could fail because you have no signal too or any other network issues.

The decryption without JavaScript makes no sense to me.

Send the bug report to apple if Obsidian does not appear in the lockdown mode list.

1 Like

Apps only appear in the exclusion list if they open an in-app Safari browser, which Obsidian doesn’t.

Is there any way to open an in-app Safari browser tab in Obsidian? That would make Obsidian app show up in the exclusion list.

Where is that from?
The docs say something different:

Only apps that you have opened since enabling Lockdown Mode and which have limited functionality appear on this list.

From: https://support.apple.com/en-us/HT212650

Obsidian not showing up in the exclusion list is an Apple bug, there is nothing we can do about it.
As said above, it does show up in the exclusion list for some users.

If Obsidian

then perhaps Obsidian could detect this condition (not some kind of network failure, but that some critical data API is not available) and display remediation steps for the user.

There appears to be an iOS API for explicitly detecting lockdown mode and showing the user messages in response to lockdown mode for the first time.

Maybe if Obsidian implements these checks or dialogs, then the app will reliably appear on the lockdown list? I haven’t used these API myself, so I can’t say for certain, but it could definitely improve the user experience of:

  • Obsidian sync working
  • Enable lockdown mode
  • Obsidian sync silently failing
  • No remediation for user without disabling lockdown mode on entire device, because app does not appear in the potential exclusion list in Settings

Lockdown mode, for some users, is a matter of personal safety. I hope that Obsidian developers can consider taking another look at this matter. I’ve been a very happy user of the product for a while, but this is a showstopper for me.


Is this fixed yet? I stopped using Obsidian on mobile months ago for this reason