Obsidian suddenly slow/crashing on mac

Hi everyone,

Absolutely loving Obsidian so far! It’s really helping me organize my different projects into a cohesive system.

I’ve just been having some trouble over the past few days with Obsidian suddenly becoming slow and crashing when I try to access certain notes. Whenever I click on specific notes (it’s always the same ones), the cursor stops flashing and I cannot type or interact with anything in Obsidian. After a few seconds, I regain intermittent control enough to click on another note. Once I do, Obsidian runs normally again. If I remain on the problematic note long enough however, Obsidian shows a blank screen and I have to close the program.

Things I have tried

I tried copying all the content of one of the problematic notes into a new empty note. When the new note was still called “Untitled”, Obsidian would run just fine while it was open. Once I deleted the old problematic note and renamed the new one the original name, Obsidian would become slow again each time I opened that note. Not sure what is going on here but might it have something to do with the name of the note being linked to from others?

Also, if I open a new note and set up an alias with the problematic note’s title, Obsidian starts to freeze again when that note is open.

I tried disabling plugins but the problem persisted. I tried restarting Obsidian and restarting my computer, but neither made any difference.

Please continue below this line: →

What I’m trying to do

I’m trying to stop Obsidian from freezing each type I open up specific notes so that I don’t feel reluctant to click on that note and slow down my work flow.

Funnily enough, the note that this originally started happening with was title “Waiting”. I was describing the concept of waiting and each time I went to the note I had to wait while the program froze. This is besides the point of course, but the irony was not lost on me.

To be clear though, this is happening for multiple notes, not just one.

Other strange things that may or may not be related: certain folder icons disappeared suddenly. This doesn’t seem related but I thought I’d mention it in case.

Anyway, thanks so much for helping me out! I really love using Obsidian and can’t wait to get back to it!

That sounds odd.

First up, can you post your “Show debug info”? Run that command inside Obsidian.

Second, can you think of anything peculiar about the problematic note? Any embedded media? Special characters? Scripts? Anything you can think of. Writing about Waiting doesn’t count. :slight_smile:

Thanks so much for the quick reply!

Here is my debug info:

Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T6000 21.3.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Dracula + LYT v0.0.0
Snippets enabled: 2
Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

With regards to anything particular in that note, unfortunately no. It is happening to several different notes now and they all have different kinds of content. Some have embedded drawings while some have only text. Some notes are completely blank and they still cause Obsidian to freeze (all the notes in question though have links to them). The strangest thing is if I change the name of those blank notes, the problem goes away but only for that note.

Thanks again for your help!

You should also test with the default theme and snippets turned off.

If that solves it, you can try to update the themes. Or share the snippets here to see if anyone can suggest improvements.

If it still happens with default theme, then that would need a bit more investigation. And an answer about any clues you can think of.

Tested with the default theme and turned snippets off, still no luck.

Currently there are a total of 5 notes that do this. They are not all in the same subfolder, but they all belong to a parent folder.

If I change the title of any of those five notes, even by one word, the problem goes away for that note.

They all have backlinks, but not necessarily with each other.

Beyond that, I really can’t see any other clues that might be helpful.

Any thoughts? Thanks again!

Quick update:

It looks like for some of the notes, it doesn’t matter if I change the title. They still cause Obsidian to freeze if I open them.

Where do you store this vault?

Are you using cloud-syncing tools? (Obsidian Sync, iCloud, Dropbox, Google Drive, OneNote, etc. etc.)

What can you say about this parent folder? Anything special about it?

I have the vault stored in a folder on my desktop and I use Obsidian sync to sync to my iPhone. Should I store it somewhere else?

The parent folder has a bunch of subfolders within it. All of the problematic notes are within these subfolders and link to other notes also in the subfolders of this parent folder. When I move one of the problematic notes to a completely different folder unrelated to this parent folder, the problem persists for that note.

With regards to Obsidian sync, tbh it has not been working that well and I often have to wait quite a while for changes made on my computer to appear on my phone or vice versa. In some cases, entire folders have not transferred over even days after making them. I was going to make another post about this later but perhaps it’s related to my main problem?

Probably unrelated, but you mentioned you keep your vault on the Desktop. Which should be fine unless iCloud’s Desktop and Document sync is ON.

Check if “Desktop & Document Folders” sync is checked or not in Settings > AppleID > iCloud Drive > Options.

1 Like

I just checked and iCloud’s Desktop and Document sync is not on. However, in the same iCloud Drive options menu, Obsidian is selected.

If Desktop and Document sync is not on, having your vault on the Desktop is fine. So, unrelated.

The iCloud Obsidian sync preference checked is fine, that’s only going to sync the iCloud Drive/Obsidian/ folder.

It definitely sounds like you might have other issues going on. But I don’t know what or why.

Personally, even if you have Desktop unchecked in iCloud, I still wouldn’t trust it. But that’s just me. I always avoid folders like that. They have too many potential automatic integrations.

I’m not familiar enough with Obsidian Sync. But there is a sync log you could check for errors or warnings. You can also open up “Developer Tools” (alt-Cmd-i) and check the Console. There might be errors there.

If you do decide to try to move the vault, I suggest backing up first. And if you go to the vault switcher, there are 3 dots beside your vault. And a command “Move vault…”. If you do it from inside Obsidian, nothing should break. But I don’t use Obsidian Sync right now, so take this advice with a grain of salt.

Yeah I do think there are multiple problems going on. Where do you suggest I save my vault if not on my desktop?

I checked the sync log and it doesn’t list any errors. I opened up the developer tools and took some screenshots of the console:

I’m really at a loss of what to do. I haven’t been able to work on my notes for several days now.

Unfortunately I don’t have enough technical knowledge to figure out what the developer tools are telling me.

I tried moving the vault location but it made no difference. Any suggestions on better places to store the vault would be helpful though.

My vault no longer syncs to my phone using Obsidian sync (it shows up as an older version and none of the changes I make on my desktop appear on mobile). Any of the notes that cause problems that are on both my computer and phone do not cause any problems when opened on my phone (they are also older versions of the notes).

Sometimes opening a note will now cause my entire computer to freeze with the rainbow ball, not just Obsidian.

Any other ideas or next steps I should take would be incredibly helpful. Thank you so much!

It could be related to one of your plugins, and in that case the following plugin might help you identify the culprit:
You’ve also got the option to use this plugin to hopefully narrow it down faster:

So try playing around it with that, and see if it’s related to one of the plugins, or not.

For whatever reason when I install that plugin and put it in the plugins folder, Obsidian tells me it “failed to load”. I’m going to try to figure out why, but the thing is if I run Obsidian in restricted mode with all the plugins off, the problem still persists so I’m not sure the issue is plugin related.

Does moving your vault contents to a fresh vault help?

  1. Close any open vaults and quit Obsidian.
  2. Move or copy all the contents of your vault except the .obsidian folder into a new folder.
  3. Start Obsidian and add the new folder as a vault.

So this issue was resolved simply by deleting all of the notes that were being problematic and pasting their contents to new notes. Weirdly, I had to stop using aliases for the new notes as if I kept them, the problem would persist. I truly don’t understand what was causing the issue in the first place but at least I found a workaround! Thanks for your help everyone!

1 Like

Strange! Are you unable to use aliases generally or just in those notes?

I can use aliases generally but those notes get all buggy when I add them back in. I truly have no idea what happened here but luckily it’s no longer affecting my work flow!