Obsidian snap package breaks plugins like "Obsidian Git" that need to call external binaries

Steps to reproduce

  1. Download the (at the time of writing) recent Obsidian snap package.
  2. Install the snap – btw, are there any installation instructions or are users supposed to know about --dangerous? – as follows: snap install --dangerous obsidian_0.15.6_amd64.snap
  3. start Obsidian and select a vault on which you initialize a git repository, if not done already so, using git init
  4. Install the community plugin “Obsidian Git”.
  5. open the Obsidian Git sidebar view by pressing Ctrl-P and entering “Obsidian Git: Open source control view”
  6. nothing will be shown, even if files have been changed. In particular, the icon buttons for commit, etc. will be missing.
  7. Strg-Shift-I to look at the console error message that show that git cannot be found/executed.

Expected result

The Obsidian Git community plugin to be able to execute the host’s git command in the same way as it can when installing and using the Obsidian AppImage.

Actual result

Nothing, nada; except for a console error message.


  • Operating system:
$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 22.04 LTS
Release:        22.04
Codename:       jammy
  • Debug info:
	Obsidian version: v0.15.6
	Installer version: v0.15.6
	Operating system: #44-Ubuntu SMP Wed Jun 22 14:20:53 UTC 2022 5.15.0-41-generic
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: Solarized
	Snippets enabled: 1
	Safe mode: off
	Plugins installed: 6
	Plugins enabled: 6
		1: Advanced Tables
		2: Smart Typography
		3: Style Settings
		4: Advanced Mobile Toolbar
		5: Collapse All
		6: Obsidian Git

Additional information


We don’t take bug reports involving third party plugins. Contact the plugin dev directly using github. If the there is a problem with obsidian, they’ll contact us.

With due respect @WhiteNoise, but I suspect you might misunderstand the situation. This is not a third-party problem, but a problem how you are packaging the Ubuntu snap package.

May I extremely humbly suggest that either…

  • the snap package gets fixed so that it is allowed to access host commands,


  • document these limitations of the Obsidian snap package with respect to community/3rd party plugins?

Thank you very much!

Well, I have looked into it and I don’t think it is a bug. Some user may prefer the safeguard introduced by a strict snap.

You can try to install the snap in classic or devmode.

Feel free to open a feature request asking for changing the default installation mode from strict to classic.

Thanks for your answer, will look into the options and then file a bug to update or add documentation on the options of installing the snap.


I also ran into this, where the only plugin I have not gotten working is Obsidian Git on my Ubuntu laptop. Working great on my Windows 11 PC, however.

I tried your suggestion @WhiteNoise and haven’t gotten it to work that way, either. I tried both:

cd ~/Downloads
sudo snap install obsidian_0.15.9_amd64.snap --classic --dangerous


sudo snap install obsidian_0.15.9_amd64.snap --devmode --dangerous

And in both cases upon opening my vault (with Obsidian Git already enabled), I see:

git obsidian error: Cannot run git command

In the console.

[email protected]:~/Downloads$ which git

So Obsidian still cannot access my git, trying to figure out why. Or try some other package manager just to get around this plug-in not working…

Also, according to this snap doc, the --classic will be silently ignored if it hasn’t been packaged as a ‘classic snap’. Are the hosted obsidian snap packages even capable of this install mode? In any event, even using --devmode and supposedly disabling all security is not yet working for me, so I don’t know what the root of the problem is yet.

I am wondering, has there been an attempt to get Obsidian into an ubuntu / debian apt repository? I’ve really only ever needed apt in my linux installs in the past, which seems to work pretty consistently for my needs. Would .debs have these sandbox issues?

Also, I use programs like Sublime Merge that need git access and seem to deal with this permissions issue, I installed that one with apt / dpkg so seems like that one should be possible.

And FWIW I use git across all my machines to version my notes, and pretty committed to it at this point so need to find a solution for Obsidian and Git to work nicely together.


Oh scratch that on the .deb question - just saw that there is already one hosted on the official Obsidian Downloads site and it worked like a charm, including Obsidian Git!

Out of the box opening my vault with obsidian-git already enabled:

app.js:1 Obsidian Developer Console
plugin:hotkeysplus-obsidian:43 Loading Hotkeys++ plugin
plugin:shortcuts-extender:83 e
plugin:obsidian-git:14420 loading Obsidian Git plugin
plugin:obsidian-git:15062 git obsidian message: Pulled 12 files from remote
plugin:obsidian-git:15062 git obsidian message: No changes to commit
plugin:obsidian-git:15062 git obsidian message: No changes to push

Way to go! I don’t know why using the .deb isn’t promoted more? :thinking: