Obsidian seems to delete notes with title starting with "."

Hi, I saw there were similar issues reported but they have already been closed - my Obsidian seems to delete the note names starting with “.”, e.g. “. Start Here”
Unlike other deleted notes these do not appear in my recycling bin
The first time I noticed it was the next day, I could not retrieve the file so I reproduced it, then I noticed it after a few hours and now I tried again and the file was deleted as soon as I typed the name and pressed Enter

My Setup:

  • main vault sits on OneDrive with a PC and Macbook accessing it
  • installed mobile today for ipad / iphone - local vaults synced with one remote vault from the Macbook

What I’ve tried:
I originally (as an error) had set up my mobile vaults to be saved on icloud and then obsidian synced it to a remote vault. Having looked around the forum I figured it might be a issue between icloud and obsidian sync so I deleted those vaults and opened local ones, but the issue persists.

I attached the screenshot with the last three deleted files, if I try restoring it it gets deleted straight away again

Just to add - I created pages with other titles in the meantime and they seem to still be in my vault, it’s just this particular title in various variations for some reason that keeps getting this issue

Files and folders that begin with a period (.) are hidden in Unix based operating systems. That might be what’s happening?

Try going into the vault folder in the finder and use the keyboard shortcut command-shift-period it should reveal any hidden files.

If they don’t show up then I dunno! If you’re on Windows the I dunno either!

1 Like

Thanks for the idea, I was really hoping that’d fix it, but nothing happens unfortunately… I get the same problem on my PC, but I thought it might be because of the Sync if it gets hidden on Mac… unfortunately the key combination on Mac does nothing.

It should at least reveal the hidden .obsidian folder. If you don’t see that in the vault then hidden files aren’t being revealed for some reason.

This is quite strange! I don’t have a PC or else I’d test the issue.

Just to be clear, you cannot see these files in neither Windows nor Obsidian, correct?

I believe Windows defaults to show hidden files, but you can check or change whether to hide/display hidden files (files/folders starting with a ‘dot’) by going to the “View” tab, then selecting “Options” and finding this screen:

If this is set to “Show” and you still can’t see the files in your vault in Windows, you have something else going on. You will not (never?) see these in Obsidian until you rename them to something that does not start with a dot.

I want to use Tagspaces tags with my Obidian vault. It adds a .ts (hidden file) to any location it tags… and just links the file name to their tags in that .ts file (as far as I understood from their website).
Could this cause any problems of any kind?

Thanks in advance for your help!

My post ws merged here for some similiarties… However my problem is not whether the file remains or gets delted… I’m using Windows 10. and the file seems to remain so far.
My question is, specifically: Having a .ts (json file) created inside the vault by another app (Tagspaces), would it or would it not cause any functionaltiy problems lead to loss of data cause performance issues either for Obsidian or Tagspaces?

Thanks in advance for your help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.