Obsidian reset itself, plugins and vault files vanished

I am using Obsidian v.1.0.3 in Windows. I recently upgraded to Windows 11 from Windows 10. I had approx. 50 files in my vault and some community plugins installed. Everything worked in Obsidian even after the Windows upgrade.

Today I opened the app and it looked like a fresh install. Restricted mode was turned on and no community plugins were shown. The C:\Users.…\Documents\Obsidian Vault folder is empty and its creation date is today.

Things I have tried

Checked File recovery plugin but it showed no snapshots.
Tried to search the whole computer for .md files but couldn’t find any. Used Recuva date recovery software to find deleted .md files but couldn’t find any.

What I’m trying to do

I don’t understand what happened and don’t know how to get back my vault files. Any idea?

Did you use the old help vault for your vault?
It specifically says not to use it as a productive vault as it used to get reset every so often.
With one of the recent update’s it got replaced with the sandbox vault and the a few updates later it got removed from the list entirely.

If you did use the help vault your files are here:
Win: %appdata%/obsidian/Obsidian Help
please move them somewhere else and create backups going forward.