[Obsidian Publish] Page whose title includes a dot never overrides the social card

Steps to reproduce

  1. Create a note named “test.1”
---
description: "Title has a dot"
cover: "https://slack-imgs.com/?c=1&o1=ro&url=https%3A%2F%2Fpublish-01.obsidian.md%2Faccess%2F35d05cd1bf5cc500e11cc8ba57daaf88%2F%25F0%259F%2593%2598Articles%2Fattachments%2F2022-05-04.jpg"
---

The title of this page includes a dot.
  1. Publish above note
  2. Put the published link to Discord

Expected result

It shows the description and covered image.

image

Actual result

image

Environment

SYSTEM INFO:
	Obsidian version: v1.2.8
	Installer version: v0.15.6
	Operating system: Windows 10 Pro 10.0.22621
	Login status: logged in
	Catalyst license: vip
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: Solarized v1.0.5-beta
	Snippets enabled: 1
	Restricted mode: off
	Plugins installed: 19
	Plugins enabled: 19
		1: Calendar v1.5.10
		2: Periodic Notes v0.0.17
		3: Advanced Tables v0.18.1
		4: Tag Wrangler v0.5.6
		5: Hot Reload v0.1.8
		6: Obsidian42 - BRAT v0.6.36
		7: Templater v1.16.0
		8: Sort & Permute lines v0.7.0
		9: Jump to link v0.4.4
		10: Code Editor Shortcuts v1.13.0
		11: Another Quick Switcher v8.9.1
		12: Editor Syntax Highlight v0.1.3
		13: Vim Yank Highlighter v1.1.4
		14: Vimrc Support v0.9.0
		15: Old Note Admonitor v0.7.0
		16: Limelight v1.1.0
		17: Various Complements v8.2.0
		18: Shukuchi v0.2.1
		19: Silhouette v0.14.0

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

The followings are pages on my published site.

thanks

Is this still happening?

Yes.

Ex:

Ah… sorry, The above URL is wrong.

The following URL is a correct example.

Is there any prospect of this bug being fixed? Including dots in titles is not uncommon, so if it won’t be fixed, we need to consider an alternative solution.