Obsidian permanent deletes files system trash


I’m using Obsidian 1.03 on MacOS 13. I have noticed that the deleted files in obsidian are not in the trash, even though the system trash is the destination specified in the application settings. In other words, it seems that Obsidian permanent deletes files instead of sending them to system trash…

Can you post your “Show debug info”?

Also, can you test this in the Sandbox vault, to try and isolate if this is an Obsidian or plugin or MacOS problem?

I don’t experience this. Obsidian 1.0.3 and the deleted file ends up in my system trash. (But I’m on MacOS 12.6, so I can’t test if that is the problem.)

Also can you specify exactly how you’re deleting the file? Maybe you’re running a command with a bug. I used the “Delete current file” from the command palette for my test.

I tested in Sandbox vault and it works fine so, there is a problem with my vault.

I delete a file with hotkey (there isn’t conflict with other hotkey).

I’m using a lot of plugins, I tested in restricted mode disabling community plugins but still permanent deleting files.

Here my debug info:

Obsidian version: v1.0.3
Installer version: v1.0.0
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:30 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8103 22.1.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal
Snippets enabled: 0
Restricted mode: off
Plugins installed: 68
Plugins enabled: 47
1: Better Word Count v0.8.1
2: Minimal Theme Settings v6.1.0
3: ReadItLater v0.0.16
4: Highlightr v1.2.2
5: Sidebar Toggler v0.4.0
6: Extract Highlights v0.0.18
7: File Info Panel v1.2.5
8: Prominent Starred Files v0.0.2
9: Footnote Shortcut v0.0.9
10: Wikipedia v1.0.3
11: Advanced URI v1.28.2
12: Pandoc Plugin v0.4.1
13: TagFolder v0.15.7
14: Tag Wrangler v0.5.4
15: Markdown prettifier v0.1.3
16: Frontmatter Tag Suggest v0.4.1
17: Local images v0.14.2
18: Omnisearch v1.7.8
19: Dictionary v2.21.1
20: Image Caption v0.0.13
21: Hover Editor v0.11.6
22: Local File Interface v0.1.0
23: Icon Folder v1.3.5
24: Consistent attachments and links v1.0.8
25: Filename Heading Sync v1.7.0
26: Find orphaned files and broken links v1.8.0
27: Auto Link Title v1.2.5
28: Advanced Mobile Toolbar v1.8.0
29: Simple Embeds v1.13.0
30: Folder Focus Mode v0.9.8
31: PDF Highlights v0.0.4
32: Readwise Official v2.0.1
33: Recent Files v1.3.3
34: Templater v1.15.2
35: LanguageTool Integration v0.3.0
36: Extract url content v0.12.1
37: Wikilinks to MDLinks v0.0.12
38: Advanced Tables v0.17.3
39: Custom File Explorer sorting v1.0.2
40: Table Extended v1.6.1
41: Focus Mode v1.10.2
42: Obsidian Enhancing Export v1.1.7
43: Footnote & Citation Indicator v0.3.5
44: Tidy Footnotes v0.1.1
45: Tasks v1.16.0
46: Reminder v1.1.12
47: Link Embed v1.5.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Did you restart Obsidian after turning on Restricted Mode?

1 Like

Yes, I did…

Please, more info. What hotkey? What command?

This is a long shot, but if you didn’t already, please try to set the default theme too. Who knows, maybe there is some obscure bug with the theme.

That’s… a lot of plugins.

Anyway, as a workaround, you might want to consider using the Obsidian .trash folder.

Command-backspace… but it is the same if I delete files with mouse…

Changing theme (and restarting) doesn’t solve… I will try disabling all plugins and reactivating one by one…

Thank you @rigmarole

I found the reason: last beta dropbox update. If I create a new empty vault in Dropbox and I delete a file in Obsidian or in Finder, always the same thing happens: the file is permanently deleted.

Good to know…


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.