Obsidian opens the "vault switcher" instead of the last opened vault

I don’t know how it happened but when I open Obsidian I have to select what vault I want to use. Before it opened my default vault which is actually my only vault. I’ve tried “restricted mode” but the issue persists.


Obsidian version: v1.1.16
Installer version: v1.0.0
Operating system: Windows 10 Pro 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.0.12
Snippets enabled: 0
Restricted mode: on

Additional information

Also I’m on Windows 11 22H2 22621.963, don’t know why it shows Windows 10 in the debug info.

1 Like

If Obsidian is already running and you try to open it again, it shows you the vault switcher.

It isn’t already running. That’s not a solution.

Look at your process explorer.

Yes, there was dozens of Obsidian processes, even though it wasn’t actually running, which is a bug per se, when I close Obsidian I want it to actually close. Ran taskkill.exe -im Obsidian.exe -f, it killed all instances, tried again but the issue persists.

you haven’t killethem all. Restart your computer.

I restarted and now it works as usual but I can assure you I had killed all the processes, I’m not a moron. Obviously there’s something wrong since it’s not the first time it happened, it’s not normal that I have to manually kill processes or restart the computer to make it work. Thanks anyway dude.

1 Like