Obsidian on Chrome OS - "Failed to open, no permission to access folder."

Things I have tried

Installing Obsidian using Flatpack was difficult. I managed to install it using these 2 articles where I had to fix problems with Linux by “updating packages” (I’m not a developer):


Now my issue is that I can’t open a folder as a new vault. I get the error message “Failed to open, no permission to access folder.”

The vault I have was downloaded here: LYT Kit v5 Overview

What I’m trying to do

I want to open up the vault and start using Obsidian using the vault.

If you are running Obsidian from Linux on ChromeOS, the folders you are storing data in need to be accessible to the Linux VM. (Linux on Chrome OS runs as a Virtual Machine, and file access is kept separate from the rest of the Chrome OS environment for security)

Open the Files app on your Chrome OS device, then navigate to the folder where your notes are (Probably somewhere in My Files, I suspect)

Two-finger tap on the folder name (acts like a right-click), or tap on the three dots in the upper right of the screen, to see the sub-menu, which should have the option: “Share with Linux”. Click on that.

Now that folder should be available for Obsidian to open.

Hopefully that helps.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.