Obsidian not starting on a Mac

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

open Obsidian

Things I have tried

uninstall, download, turn off Mac Sonoma 14.2.1, restart, and re-install Obsidian. Connect my mobile to the Internet. Wait for syncing.

Obsidian will not start, and Obsidian is not open.
Most of the problems were with PCs. Should I find out where the plugin software is on a Mac?

I am trying out plugins on my mobile. I also worked on notes on my mobile. My mobile is working fine. There may be a new plugin for my Mac, but I am not sure. I connected the mobile to the Internet to sync. I thought maybe the problem was syncing. I looked in the help files but could find nothing.

I have had no luck. The line that is supposed to move back and forth does not move even after waiting for 15 minutes.

I probably need to remove plugins from my Mac. Where would I do that?

I’m having trouble understanding. It seems that you are talking about Obsidian on Mac not starting at all.

But then you are talking about mobile and syncing, and waiting for things to sync. So I’m not sure what exactly the issue is.

What sync tool are you using? And why do you think the app not starting is related to syncing? Are you seeing some popup, or warning, or indexing?

If you can’t start the app and you think it might be a plugin, you can try this:

  • Close Obsidian
  • Backup your entire vault first. (Zip it up or copy it somewhere safe.)
  • Go to YourVault/.obsidian/ (it’s a hidden folder)
  • Delete YourVault/.obsidian/community-plugins.json
    • Just delete that one single file.
    • That is the list of loaded plugins. Deleting this file will keep all your plugins and settings, but will make them unloaded.
  • Try to open Obsidian.
  • If it loads, you can try updating all your plugins to the latest version. Or try turning them on one by one to see if you can find which one is causing the trouble.

That would be either the loading cache or the loading workspace progress bar.

But trying out new plugins should not affect the cache or the loading of the workspace.json (which latter I’ve had some issues with on my own non-Mac install).

Let’s focus on the desktop now and rule out syncing issues (although, again, I have no experience with Obsidian Sync if that’s being used).

So after backing up and deleting the .json file as @rigmarole has suggested, you can even try renaming your config folder (if it was .obsidian, then that) and see if Obsidian lets you in.
Then we’ll take it from there.

Otherwise try deleting the workspace.json file if it was the culprit.
You can make backups of individual files in config folders by copy+pasting back into the same folder. Try the renaming convention workspace.json.bak or workspace.json.backup and also community-plugins.json.bak, etc.

1 Like

Thank you both. ( I am not sure if I should use the at sign for rigamarole.) Anyway @Gino and Rigamarole you both were very helpful. I trashed my community plugin file and Obsidian opened.
I am slowly adding back my plugins. Very little in my vault completely works. So, I impulsively added plugin that might help. After this experience with too many unknown plugins, I will be more careful.


Good to hear you’re making progress. Just double checking: Don’t forget to update your plugins too. I don’t think community plugins ever auto-update.

Thank you. Will do