Obsidian lost setup

Today morning I started Obsidian and it asked for Vault opening. It was strange, but I did it. Opened my only Vault. All notes are there but Obsidian is reseted to all defaults (plugins, setups, themes, shortcuts…).

It looks like brand new installation.

I checked Vault folder. All files are there (plugins, themes…) but Obsidian doesn´t see it.

I spent many hours to set it up. I can not imagine, that I will have to do it again.

1 Like

It happened to me yesterday. The theme reset to default; all plugins and custom css disabled; both on desktop and mobile app.

UPDATE: Its happening again. All settings reset when I opened the app just now. Dont know whats happening. I did a fresh install just yesterday.

The same story. I didn´t changed anything for days and today settings reset.

Plugins are in folder, but Obsidian is not using them. :sneezing_face:

I have 0.12.8 version, so maybe this update damaged it.

I am not running beta. Yet, I have this issue. So I don’t think it is a bug with an insider build.

Are you using a third party sync service? Dropbox, Icloud, onedrive?

No, I don´t.

I use iCloud

Update v0.12.9 didn´t solve my issue. Still the same problem.

Obsidian in default mode.

I realized that:

When I installed Obsidian for the first time, it was here:
d:\Documents_CESKO SLOVENSKO_\Julius Meinl\Obsidian\

Than I created new Vault called Lukas and Obsidian created new folder Lukas:
d:\Documents_CESKO SLOVENSKO_\Julius Meinl\Obsidian\Lukas\

In this folder Lukas with all notes was created folder .obsidian, where all created settings were stored.


Now, since yesterday, Obsidian is creating new settings folder not in Vault folder Lukas, but in level up folder OBSIDIAN.


So I copied all content from .obsidian folder to new .obsidian folder level up, it helped and solved my problem.

But why Obsidian changed settings folder location and is looking for it in different folder, is still question for me.

I have the same problem. In my case, this happened after I moved my vault folder in the folder “Obsidian” created by Obsidian App iOS. A further but related issue: my computer didn’t recognize the “Obsidian” folder in iCloud, which motivated me to move my vault folder again in the original position.

Are you sure you didn’t make this change? Are you sure you when obsidian asked for vault opening you picked the Obsidian directory insted of Lukas?

I am still facing this issue. Default theme and settings every time I launch the application on Windows.

Yes, this is it. Probably after new version installation - Obsidian forgot Vault and asked for new one, I picked the Obsidian folder, not exact Vault (Lukas) folder. It found all NOTES in subfolders, but no configuration. So it creates new one and looks that everything is OK, except of config.

Thanks for help. :+1:

I am going to close this thread. @Obsidian-GT I suggest you open a new one specific for your problem. I wounder if Iclould on windows is the issue for you.