Obsidian keeps overriding my browser for http(s) links in mimeapps.list on Linux

On Linux, every time I open Obsidian, it adds itself as the scheme handler for x-scheme-handler/https and a number of others in my ~/.config/mimeapps.list. I don’t want this, I want my browser to be the handler for those. I have to keep manually removing these entries from the file which is getting annoying. How can I make Obsidian stop doing this?

4 Likes

Same for me on Arch Linux. It’s impossible to prevent Obsidian from doing it over and over.

Same here, also on Arch Linux. When using auditctl I can see that the culprit seems to be mimeo, but I can’t find out how it gets called.

Steps to reproduce

  1. Set a default web browser :
  • xdg-mime default firefox.desktop x-scheme-handler/http
  • xdg-mime default firefox.desktop x-scheme-handler/https
  1. Check the default browser
$ xdg-mime query default x-scheme-handler/https
firefox.desktop
  1. Start Obsidian (empty vault, no community plugin, no snippet, default theme)
  2. Check the default browser
$ xdg-mime query default x-scheme-handler/https
obsidian.desktop

As a consequence, all future http and https links will try to open with Obsidian

Did you follow the troubleshooting guide? [Y/N]

Yes

Expected result

No modification of the default browser

Actual result

Modified default browser

Environment

SYSTEM INFO:
	Obsidian version: v1.5.3
	Installer version: v1.5.3
	Operating system: #1 SMP PREEMPT_DYNAMIC Fri, 05 Jan 2024 16:20:41 +0000 6.6.10-arch1-1
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

Similar to Obsidian keeps overriding my browser for http(s) links in mimeapps.list on Linux

How did you install Obsidian?

First with Archlinux official repo, then I tested with the Appimage from obsidian.md and had the same behavior

This is not something that we do. I think it’s something else on Arch that changes your default browser to obsidian.