Obsidian issues in Ubuntu 24.04

What I’m trying to do

I encountered several issues when using Obsidian in Ubuntu 24.04.

I installed Obsidian using the following command line:

sudo snap install obsidian --classic

The issues I encountered includes:

  1. The Templater plugin’s Folder templates didn’t work when I created a new file. (I suspect it is because User Script Function didn’t get called.)
  2. When I click an external link, the link opens in a separate window of Chrome browser (instead of opening in a new tab of the same Chrome browser)
  3. The Chinese input doesn’t work.

Do yourself a favor, remove the Snap install and instead use the appimage. The appimage is the only officially supported distribution format for Linux, and it is the only format against which the developpers want to consider bugs.

1 Like

I tried to install AppImage. After installing FUSE and change the file permission, I issued the following command (note I have to add --no-sandbox, reference):

./Obsidian-1.6.5.AppImage --no-sandbox

And then I encountered the following issue:

2024-07-10 05:38:20 Loading main app package /tmp/.mount_ObsidiWoJgn5/resources/obsidian.asar
Ignored: Error: ENOENT: no such file or directory, open '/home/eric/.config/obsidian/obsidian.json'
MESA-INTEL: warning: Haswell Vulkan support is incomplete
libva error: /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so init failed
2024-07-10 05:38:20 Checking for update using Github
2024-07-10 05:38:21 Success.
2024-07-10 05:38:21 Latest version is 1.6.5
2024-07-10 05:38:21 App is up to date.
[6739:0710/133825.309262:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[6739:0710/133848.397741:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[6739:0710/133848.402084:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!

The installation just freeze there.

I suspect the machine I am installing Obsidian is too old? The CPU is Intel i5-4590.

Anyhow, I then tried to download and install the Debian package

sudo dpkg -i obsidian-1.6.5-amd64.deb

It successfully installed and the problem 2 and 3 originally mentioned in the thread are gone.
The only problem left is Templater plugin still can’t recognize the user scripts.

Very strange though, if I open chrome developer tool from Obsidian, Templater plugin can then recognize the user script and successfully create the new file.