Obsidian is indexing your vault, Onedrive

I use Onedrive to sync files between my PC and my Macbook, and it has been working fine so far. Today it started saying “Obsidian is indexing your vault”, and I can’t open any files or see any of the content inside. It also takes a very long time to load obsidian. Does anyone have any suggestions?

You may have set this already, but whatever OneDrive folder your Obsidian vault(s) is in needs to be always local on both devices. If your vault is in a folder with a cloud icon (screenshot below), it will cause problems.

OneDrive sometimes resets this setting when it updates, or randomly at times for me, so that’s something to check.