Obsidian iOS performance hit after enabling iCloud Advanced Data Protection?

*Mac user, iPhone user, been using Obsidian Desktop and Obsidian iOS both with iCloud sync mostly happily for 2 years, Vault: ~21k files, ~7k folders *

A little over a month ago, I decided to enable iCloud Advanced Data Protection (ADP), which for the uninitiated (including myself until a months ago) is Apple’s long-awaited full End-to-End encryption for users’ iCloud data. In other words, Apple doesn’t store your private key on their servers - if you lose the pkey, you lose your data.

I was a little hesitant as to how enabling ADP might affect performance of the Obsidian Mac Desktop and Obsidian iOS applications, but in the spirit of security I pushed on and enabled ADP. My line of thinking was - “Apple already claims that these iCloud files are encrypted at rest on their servers, what’s the difference in turning on ADP anyways?”

What happened? Like clockwork, as soon as I enabled ADP, the performance of my Obsidian iOS app dropped way off. It now takes about 45 seconds for the app to load at all, up from the ~5s previously. What’s also curious is I’ve now noticed 1Writer, the other notes app I use in combination with Obsdian, also takes much longer to load then before ADP was enabled. As far as the performance of the desktop application, I haven’t noticed much of a performance hit here, but that’s largely what I expected since I’m running it on a MBP M1 with 32GB of memory.

Has anyone else out there experienced this? Is bad performance our new permanent fate when working with markdown files stored in ADP-enabled iCloud Drive?

1 Like

I haven’t noticed this after activating ADP, though, I did notice that files were being offloaded much more often than before on the files app in general. Since iCloud randomly decides to offload apps depending on space on your device. I cleared a bunch of things I didn’t need but that didn’t seem to truly solve the issue. Sometimes I wake up and check my folder and the Obsidian app will be offloaded. Super annoying.

So, I had to manually download my obsidian folder and vault in the Files app on my iPhone, then reindex/re-enter my vault on the mobile app to get it work. Even then, I still had to create a different config file without the plugins I use on desktop and aren’t super necessary for mobile. That seemed to help somewhat.

I’m on the testflight version from the Obsidian Discord server and since switching to that it’s been pretty smooth sailing. I don’t know if this version is different than the main one but I know they’re actively working on mobile performance per the Roadmap.

I also created a shortcut with the a-shell mini app to downloadFolder for my vault before the app opens. So i’m like waiting a max amount of time of 20 seconds, but usually like 5-10 seconds.

Hope this helps, I can share more if you need!


Thanks for this! Going to try and get on the testflight version and report back here how the performance differs if (hopefully) at all.

In terms of physical storage on the iPhone, I’m only about half full (125 used of 256GB total), so I don’t think limited storage is the issue at the moment. HOWEVER, files being offloaded might be a possible thief of performance. My vault size is 8GB and I’m seeing my “iCloud Drive” storage on the iPhone Storage page is 740mb.

A couple months back, I ran into an issue with my MacBook offloading my vault iCloud files. I found a setting called “Optimize Mac Storage” that was enabled, and disabling this setting made a world of difference and kept my files from being purged. Perhaps there’s an equivalent setting on the iPhone? Going to do a little more digging…

@offbrands Wow. I took your advice and downloaded my vault files locally in the iOS files app. The performance is now night and day. So much faster. Thanks a ton!

1 Like

Dope! Did you do the A-Shell Mini trick? Or are you manually doing it before opening?

The different config file is super helpful too since a lot of features on mobile aren’t needed as much as on desktop.

Also, 8GB vault! Dang. Mine is 336 mb and I need to delete a bunch of plugins I don’t use but tried out.

Tragically, there is not. (I’m glad the other thing helped!)

1 Like

No I was just downloading the vault manually to the iPhone using the Files app. Tbh I’m not too familiar with A-Shell Mini - would you have a snippet or repo link for the downloadFiles command you’re using? I’d love to try it

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.