Obsidian installed via Snap prompts to allow settings change on each launch

Steps to reproduce

  1. Install obsidian via snap
sudo snap install obsidian_0.10.13_amd64.snap --dangerous --devmode
  1. Open Obsidian.

Expected result

I expect to see the “Allow settings change?” prompt once and have it remember my choice.

Actual result

This prompt appears every single time I open the app. I press “Yes” every time yet still recieve the prompt.
I speculate this is due to Obsidian not properly checking if it already has changed its url scheme handler and attempting to do it every launch, resulting in this annoying bug.


  • Operating system: Ubuntu 20.04
  • Obsidian version: Obsidian 0.10.13 Snap

Additional information


Are you sure this isn’t something you messed up in your installation?

What’s your installer version?

Thanks for the reply! How can I check the installer version? I believe Snapcraft is the “installer”.
I used the 0.10.13 .snap file downloaded from the homepage. I installed it using the command in my original post (sudo snap install obsidian_0.10.13_amd64.snap --dangerous --devmode). I am using a very fresh install of Ubuntu 20.04.

1 Like

is there any reason why you are using devmode?

I see the same. I’m on ubuntu 18.04 LTS, using obsidian_0.10.11_amd64.snap and did not use --devmode

It’s slightly annoying.

EDIT: problem still there after update to 0.10.13

1 Like

Can you let us know the following?

  • the output of xdg-mime query default x-scheme-handler/obsidian?
  • the output of xdg-settings get default-url-scheme-handler obsidian?
  • whether/where does obsidian show up in your ~/.config/mimeapps.list?

Edit: @jacksondotsh you can check your current and installer version in Settings > About



under [Default Applications]

Edit, problem still present in 0.11.0.
But further down this thread a fix is promised for 0.11.2 :+1:

Also having this issue on Ubuntu 18.04.
$ xdg-mime query default x-scheme-handler/obsidian
$ xdg-settings get default-url-scheme-handler obsidian

Obsidian appears in ~/.config/mimeapps.list.
It doesn’t seem to matter whether I allow or not, I get prompted every time I start Obsidian.

I’m at a loss here. The only thing I can say for now is that this is not a problem with the AppImage.

I am also having this issue (Ubuntu 20.10)

will be fixed v0.11.2


I am having the same issue, while on v0.11.3.

$ xdg-mime query default x-scheme-handler/obsidian
$ xdg-settings get default-url-scheme-handler obsidian
$ grep -i obsidian ~/.config/mimeapps.list

Not that actually. I had an old installation of Obsidian, updated by Obsidian itself, not by the snap engine. So when I reinstalled Obsidian using a new snap, the issue went away.

I have the same problem on Obsidian v0.12.19 freshly installed from the snap image provided on the main website.

Info asked for above:

machine:~$ xdg-mime query default x-scheme-handler/obsidian
machine:~$ xdg-settings get default-url-scheme-handler obsidian
machine:~$ cat ~/.config/mimeapps.list | grep obsidian
machine:~$ echo Shows under [Default Applications]
Shows under [Default Applications]

EDIT: I managed to change it by changing the line x-scheme-handler/obsidian=obsidian.desktop by x-scheme-handler/obsidian=obsidian_obsidian.desktop in the file ~/.config/mimeapps.list. Hopefully I did not break anything else by doing that.

╭─[email protected] ~  
╰─➤  xdg-settings get default-url-scheme-handler obsidian
xdg-settings: default-url-scheme-handler not implemented for xfce

╭─[email protected] ~  
╰─➤  xdg-settings set default-url-scheme-handler obsidian obsidian_obsidian.desktop                          1 ↵
xdg-settings: default-url-scheme-handler not implemented for xfce