Obsidian Image Linking Error Post-Update in iOS Wine Tracking Application

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I’ve been using an iOS shortcut to automate the creation of Markdown files in Obsidian for a personal wine tracking application. This application is designed to seamlessly capture wine notes, details, and bottle images after tastings. The shortcut works by taking a photo of the wine bottle, saving it with a specific filename format to a predetermined location, and then creating a Markdown file in Obsidian that contains the wine notes and a link to the photo. This system was functioning correctly until a recent update.

Things I have tried

I have verified that the filename and path in the Markdown file match the photo’s saved location. I’ve also checked for any potential typos or discrepancies in the file path and name. Additionally, I’ve looked through the help documentation for Obsidian and searched the forum for similar issues but have not found a solution. In an attempt to resolve the problem, I cleared Obsidian’s cache and confirmed that the application has the necessary permissions to access the image folder. I also ensured that any plugins used for file handling are up-to-date.

Despite these efforts, the images are not displaying in the notes. Instead, an error message indicates that the file could not be found, suggesting that Obsidian cannot locate or recognize the newly added image files. This issue seems to have coincided with a recent update to either iOS, the shortcut, or Obsidian itself.

Any help greatly appreciated!

Screenshot 2024-03-11 at 09.22.59

Try editing the shortcut in such a way that the image reference is:
![image|500](<SavedPhotoMedia.FileExtension>)

  • In other words, use markdown format and </> signs to wrap the file and extension in – the problem could be the whitespaces in the filename.

This worked in editing mode but the picture did not display in reading mode.

I found a solution… I converted the image.jpg text variable to md in iOS shortcut and then used this new variable which rendered the image