Obsidian ignores OS default app on Ubuntu

Steps to reproduce

Go to system/file explorer
Find a .md file
Right-click → Properties
Select “Open With” tab
Set a custom text editor and click “Set as default”
In Obsidian, try to right click any md file and click “Open in default app”

Did you follow the troubleshooting guide? [Y/N]


Expected result

Opening the markdown file in the chosen text editor

Actual result

Opens in OS text editor “gedit”, not my chosen one (specifically Sublime Text)


Ubuntu 22.04.02, everything updated to latest including Obsidian (1.3.4 snap).

Additional information

If I double-click an md file in the OS file explorer, it opens in the correct text editor.

1 Like

Obsidian cannot be set as default markdown editor in any OS. Obsidian manages one vault at the time not one note at time.

I don’t think this answers the issue. The problem isn’t setting Obsidian as the default app for opening md files, its that Obsidian doesn’t open files using the app that IS set as the default app for md files.


I’m having a similar issue when selecting “Show in system explorer” from the menu. The default system explorer (Nemo) isn’t selected. Instead, Obsidian shows the file in Thunar. All other application seem to be honoring the default system explorer. (Ubuntu 22.04)

we have no control over this, we get what electron provides.
I think there maybe multiple places where to set the default on linux and the method electron uses may result in another program being opened that the one you expect.

Good point. I’ll dive into this. Also, FWIW, I’m using the latest insider build and installer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.