Obsidian Helper (renderer) @ 100% CPU all the time

Using the M1 version of Obsidian (Thank you!) but my CPU is always at 99.5% on my Mac Mini. My vault is iCloud and I have several hundreds of notes and files. I turned off graph plug-in but it didn’t help.

1 Like

Some indexing is normal in the begining.
Let’s do for a process of elimination.
Does it happen if you turn off icloud?

Opening a smaller Vault that is not on iCloud seems to work normally. I will wait to see if it finishes the indexing. There are 2200 files

After a few hours. It seems to be working normal. So, I guess you were correct, it might have been the indexing. Thank you

A few hours is a lot. How long are the files in your vault. I wounder if one of your files is confusing our parser.

I have ~3 GB of files. Including many non .md files (PDFs, JPGs) which account for most of the size.

I started experiencing the same Mac client problem after I relocated my vaults to iCloud (to allow iPad syncing).

Activity app indicates:

Obsidian Helper (renderer) @ almost 100% CPU

Any suggestions at further trouble shooting?

A couple observations

  • Background:
    • Current Mac Version: 0.12.10
    • Size of my DEFAULT vault is < 40mb
  • No such problem before moving vaults to iCloud
  • The iOS client is NOT experiencing any similar problem on same vaults
  • When it hangs it seems to aways be a the start of keyboard entry
    • Doesn’t accept keyboard input or mouse clicks
      • But can be terminated by clicking Red circle in title bar
    • Happens more frequently when moving focus off Obsidian to another application and then back (but not aways)
  • Very intermittent
    • Restarting Obsidian several times consecutively
      • It sometimes fails / sometime doesn’t
    • Happens > 75% of the time :frowning:
1 Like

yes, wait until it has done indexing.
It may take a long time if you have some BIG and/or malformed markdown file (>100KB)

Thanks for quick response and suggestion:



  • files: 522 (excluding a few larger referenced PNG files)
  • largest: 33736 bytes
  • average: 1682 bytes

Further observations:

It doesn’t look like an indexing problem:

  • I tried waiting for 10 minutes (Elapsed = CPU = 600 seconds) and it doesn’t resolve :frowning:
  • While it pins the CPU at close to 100% there is no disk activity being reported by Activity app for any of the 3 Obsidian processes.

I suspect it may be iCloud related because:

  • Copying a DEFAULT vault back to the system disk and accessing it from there doesn’t manifest the problem :slight_smile:

Very weird… Please let me know if I can I provide any additional information that might help?

I have this same exact issue. Vault located on iCloud. As soon I start typing, the editor window I’m typing in hangs for 1 to 2 seconds. I can see the “Obsidian Helper (Renderer)” spike to 100%. I’ve been using this vault for more than six months. This behavior just started happening recently, and I can’t pin down when, but it has to be within the last couple of months. It’s kind of unusable while this is happening, as you can type ahead of the renderer and have to wait for the letters to show up.

Similar problem here, it’s making the whole iCloud/iOS/Mac combination frustrating.

I don’t know if this is helpful, but as a troubleshooting measure, I deleted Obsidian (with CleanMyMac X). Grabbed the latest installer. Pointed it to my vault. It reindexed about 1500 files. This took about 45 minutes! My machine is an iMac i9 with internal SSD. On my other machines and iPad, this takes seconds to complete.

I did some troubleshooting. The latency disappeared when I turned on plugin safe-mode. I started at the end of my list of plugins and turned them all off, tried typing to see about the latency, and then turned them back on. The culprit in my case is the Checklist plugin. When enabled, it cases the 1 to 2 second latency when typing, and the 40 minute indexing time. I disabled the plugin, and repeated my uninstall and reinstall routine. This time indexing was maybe 5 seconds, and I have no CPU/latency issues with it disabled.

1 Like

Thanks for troubleshooting:

I just checked and I don’t have the Checklist plugin installed / enabled. So in my situation the root cause must be different.

As a workaround for now I am keeping my vault local and syncing manually using GoodSync.

Same here with vault on documents icloud, (not icloud drive). following

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.