Obsidian Hangs when deleting a file

When I delete a file in my vault, Obsidian hangs.

Versions:

  • Obsidian: Version 1.0.0 (Installer 0.15.9)
  • System Version: macOS 12.6 (21G115)
  • Kernel Version: Darwin 21.6.0
  • Boot Volume: Macintosh HD

Things I have tried

I searched and found a similar thread called “Deleting Folder Cause Obsidian to Hang” but it did not solve the issue for me.

  • I disabled community plug-ins and restarted Obsidian and still see the issue.
  • I tried using another vault with completely different content and the issue persisted.
  • I created a brand new vault and added 1 file and it worked - I could delete files!!
  • I started playing with the options under “Files & Links” and I found that if I set “Deleted files” to be “Move to Obsidian trash (.trash folder)” then I can delete!

However, if I set it to be “Move to system trash” then when I try to delete a file it hangs.

I’d like to get to the bottom of why this is happening. Any suggestions on how I can further debug this issue?

Thanks much!

Try going to the obsidian site and downloading the new installer and running it.

I use “Move to Obsidian trash (.trash folder)” and haven’t noticed this, but out of curiosity do you have any external drives attached? Have you noticed any lag opening the trash from Finder or the dock? Does Obsidian hang every time you delete a file or only sometimes?

Probably unrelated to your issue but a recent build of macOS (12.5.1? 12.6?) caused my trash folder to lag 2~3 seconds when opening (by clicking the dock icon) or trying to empty it. After the initial lag, opening would be fine for a day or two then happen again. If no external drives were attached, this wouldn’t happen. Felt like years ago of of waiting for a drive to “spin up” and the Finder collecting the .trash views from all the drives. Updated to 12.6.1 a few days ago and haven’t noticed it yet. :crossed_fingers:

1 Like