Obsidian hangs on the "no file is open" screen before opening homepage

Hi, I’d appreciate some guidance on how to troubleshoot the problem below. Thanks!

What I’m trying to do

I’m trying to open Obsidian without it hanging on the “no file is open” screen for several seconds before opening the homepage. This isn’t as annoying on desktop (Windows), but it does impact my workflow on mobile (Android).

This started happening a few weeks ago when I brought a bunch of old notes from OneNote into Obsidian. I moved the content by copying and pasting it. The content was “ink” written with a stylus. I assumed it would be imported as an image but it was instead imported as a string of characters (which does actually display the ink correctly). However the string of characters was very very long resulting in some notes being hundreds of kb in size. This would cause Obsidian to hang on the “no file is open” screen and index a few tens of files every time (on both Windows and Android).

Things I have tried

I tried replacing the “ink” content with actual images / screenshots. This helped a little but index times were still 10 or 20 seconds or so.

I think tried deleting the notes entirely. Indexing time is down to 4 seconds or so, but I don’t understand why it’s still indexing at all.

Other Considerations

Currently no md files are greater than 20 kb.

We have an attachments folder in the vault which includes several images, videos, audio which can get up to 5,000 kb in size (those usually 300 kb is more common).

The vault contains only approximately 450 items, 70 of which are attachments (files other than md).

Next steps

I will try removing some of these other files, or perhaps even rebuild a new vault from scratch and copy files over slowly checking for the issue to reemerge.

It would come down to implementation on the Obsidian side, but assuming that they used some of the tools available on Android it could be possible that the files are missing. Android uses a mechanism that will index images and media that make them available to other applications. See this SO question.

Try a reboot of your phone to see if that fixes it. If it is does, you will have a better direction on how to solve this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.