Obsidian goes to blank screen after 30 seconds

Things I have tried

Hi all,

Yesterday I tried to open what was apparently a corrupted (not virus, just corrupted) PDF in Obsidian. After that I wasn’t able to interact with any of my vault files, and now when I open obsidian the vault opens, and then it goes to a blank screen within about 30 seconds. I tried checking for updates etc - which I’ve seen in some of the help posts. But because the screen goes blank so fast I can’t get it to complete any of those troubleshooting steps.

I have uninstalled obsidian, but it didn’t appear to remove any of its settings, so it is automatically opening the same vault with the same settings on reinstall.

Further more, I use obsidian sync and was able to sync, delete the bad file and continue using my vault on a different computer last night.

What I’m trying to do

I’m not trying to do anything fancy, but it would be a great help if anyone had any ideas.

Edited to Add: Running Windows 11 and to get obsidian to close I basically have to close it from the Task Manager

I was in too much of a rush and couldn’t get some critical things done this morning.

So,

Renamed old vault folder, and then setup like I was on a brand new computer with a sync. Which so far seems to be working.

I’m guessing that maybe some of the plugins, or indexing stuff has a little bit of a hickup due to that erroneous file. So maybe you could try and disable all plugins/themes, restart Obsidian, and see whether you then can get into the “original” vault again, and remove that file (if not already removed).

If that works, I reckon you should be able to enable your plugins and keep using the “original” vault (and not the copy you mentioned in the second post). I did something similar when I encountered a bug within the Dataview plugin, but it could work for you as well.

This just happened to me. I think it had something to do with me also trying to use Obsidian on an iPhone. I solved it by deleting the whole Obsidian folder in Library/Application Support/Obsidian as well as deleting the app. When I installed again from the dmg and chose the same folder I used before everything showed up again.