Obsidian git- unable to push

What I’m trying to do

I have installed Obsidian Git, and whilst I am able to commit changes from Obsidian, and push to origin using Github Desktop, I am unable to push directly from Obsidian.

When I try to push from Obsidian, the following error message occurs:

‘Pushing to https://github.com/lucyanna/Obsidian_git_backup.git fatal: could not read Username for ‘https://github.com’: Device not configured’

Things I have tried

  • Restarting Mac
  • Pushing separately vs using the create backup hotkey

Any help would be greatly appreciated!

Please take a look at the following links to see if any of the workarounds or suggestions work:

Hi, I’ve tried changing the remote URL to SSH, but it still displays the same error message?

I’ve also searched online, and there are some suggestions to ‘do chmod 600 ~/.ssh/config’.

However I’m confused as to the exact steps to do this and would be grateful if you could please help to explain it?

Link to the thread: Not able to push · Issue #39 · denolehov/obsidian-git · GitHub