Obsidian Error - Sync Issues and suddenly whiteing/greying out

I’ve been using Obsidian for a long time now without issue, syncing two vaults between a couple of Mac’s and a Windows laptop using dropbox. Recently I’ve started having a few problems. I suspect they are a related issue which is just getting worse.

Initially its started I think as a sync issue. Whilst typing in a note, my note will just start to get automatically updated as if I’m updating it on two machines at the same time. I’m normally only using one computer at a time and rarely have more than one running at a time. Whilst typing in a note it randomly starts to update itself removing what I’m typing, then retyping it in etc. I get a notification saying the file has been modified elsewhere and obsidian starts constantly removing and retyping my entries. When I read back some of my recent notes they have missing words, missing lines, missing paragraphs etc. It’s become so unstable its almost unusable.

I normally open Obsidian and leave it to update, resync with dropbox etc. reindex if need be and as I mentioned I’m using only using it on one computer at a time. I’ve re-installed Obsidian using the v0.15.6 Installer, but it hasn’t improved the sync issues and seems if anything to have made it worse with a new issue having started.

When I open Obsidian and start to work on my notes, which usually includes multiple notes open, some pinned, some not, including side bars open on the left and right, I still have the random update issues, but now after a couple of minutes of work I sudden find the whole Obsidian window greys out. I can no longer see any notes, side bars etc. the whole window just becomes one block of light grey / white colour. Closing Obsidian and reopening it, I can continue working for a few minutes before it whites out again.
I’ve been unable to find a common trigger for this, I’ve also tried disabling several community plugins I use.

This is happening on both my old MacBook Pro and a Windows Laptop

Plugin’s I use

  • Advanced Tables
  • Calendar
  • Checklist
  • Dataview
  • Day Planner
  • Kanban
  • Mind Map
  • Note Refactor
  • Outliner
  • Sliding Panes (Andy’s Mode)
  • Templater

I heavily rely on Templater, Advanced Tables, Dataview
I have tried disabling certain plugin’s but I’ve been unable to resolve the issue.
Sliding Panes seems to be an issue at times so I’ve disabled that but it still occurs. I’ve also removed the Theme I was using and currently have the default Obsidian theme but the white out still occurs.

I’ve tried searching the forum for assistance but I haven’t been able to find anyone else having the same issue.

This is pretty common. I’m surprised you couldn’t find similar threads.

The first thing I suggest you try is to look inside your vault and your vault/.obsidian folder for any “conflicted copy” files. When Dropbox has a merge conflict it makes a copy of the file. And this sometimes causes weird issues where the wrong file is getting read or updated.

The weird UI issues makes me guess (but I’m not sure) that you might have some settings files conflicted.

The next thing I recommend is preventing Obsidian from launching at startup on your computer. I find this is a source of some of those conflicted copies for me. If you are using Dropbox, it is best if you give it time to sync before you open Obsidian to be safest. Even if you don’t edit things, your settings files and plugins are busy doing things, and this can cause conflicts even if you don’t touch a thing. And of course you need to give it time to sync before directly editing a file, lest it conflict.

If it’s not that, I can’t imagine what else, unless you do have it unknowingly open on another computer, or in another app.

Other things:

  • Are your plugins all updated?
  • Can you paste your “Show debug info”?

Hi rigmarole. thanks for the quick reply

I had a look in the vault/.obsidian folder and there were a couple of workspace conflict files. The weird UI issue did actually start after I created a new workspace for a project I was working on. So fingers crossed deleting those conflict files will hopefully have fixed that UI issue.
I also found some old conflict files from 2021 in the .trash folder which I’ve now also deleted.

I’ve never had obsidian launch at start up. I do usually let the computer boot up and sync dropbox before I start obsidian.

I had updated to the latest installer at 0.15.6 which seemed to coincide with the issues starting. I’ve since reinstalled with v0.15.9 and also updated all the community plugins I use.


Show Debug Info

SYSTEM INFO:
	Obsidian version: v0.15.9
	Installer version: v0.15.9
	Operating system: Darwin Kernel Version 19.6.0: Mon Apr 18 21:50:40 PDT 2022; root:xnu-6153.141.62~1/RELEASE_X86_64 19.6.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 11
	Plugins enabled: 8
		1: Advanced Tables v0.17.3
		2: Calendar v1.5.10
		3: Checklist v2.2.5
		4: Dataview v0.5.41
		5: Templater v1.12.0
		6: Note Refactor v1.7.1
		7: Outliner v2.3.0
		8: Day Planner v0.5.8

RECOMMENDATIONS:
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


I’ll follow the Show debug info suggestion and try it with a Sandbox vault once I’ve sussed out how and I’ll also have a try with the community plugin’s disabled.

Since posting my reply above, I’ve been updating my daily notes in obsidian. In the 20 minutes I was updating the UI glitch of whiting out the window must have happened around every 2 minutes or so. Each time I had to close obsidian and reopen to continue typing my notes.
I then deleted all the workspace files that weren’t previously deleted as conflicting, but the UI issue continued.

For the last 5 minutes I’ve been updating my notes with community plugin’s disabled and the UI issue hasn’t occurred once. So its looking like an issue with one of the plugin’s.
I do use dataview elements on most pages, so I’ll reenable community plugin’s and bring them back on one at a time to see which one causes the problem to return.

Thanks for pointing me in the right direction :+1:

1 Like