Obsidian doesn't recognize tags to the indent line under header

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

I found that if I added a new tag to the line under a header with an indentation/tab at the beginning of the line, Obsidian would not recognize the new tag.

I don’t know if it’s supposed to work like this or if it can be fixed by some settings.

Things I have tried

I did some search and didn’t find any explanation. I tried to reproduce the problem and upload the screenshot here.

As you can see in the picture, tags to items under header1 were all recognized automatically. Under hearder2, you can see that I added an indentation and "- " to item4, which caused tag5 and tag6 not recognizable. This also happened to line1 below.

Any idea how i can fix the problem or maybe I should just remove the indent to make things work. Thanks!

You’ve stumbled on one of the most disliked parts of Markdown.

- item4 and - item5 here aren’t in a list. You’ll notice the font is different. Tabbing or four spaces, if not in a list, will create a code block.

See → https://www.markdownguide.org/basic-syntax/#paragraph-best-practices

You’ll want to write it like this:

# header 1

List1 #tag1
- item1 #tag2
- item2 #tag3
List2 #tag4
- item3 #tag4 

# header 2

- item4 #tag5
    - item5 #tag6

Thank you! You’re so awesome! This completely cleared up my confusion. I realized that I shouldn’t treat the header as a list name or an upper level of an outline. Thanks again!

Yeah, it’s annoying until you get the hang of it. Also, I put List3 in the example above, but that’s not needed. This is also fine:

# header 

- item4 #tag4
    - item5 #tag5
        - item6 #tag6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.