Obsidian does not render properties correctly when using templater after update

Steps to reproduce

Install the templater plugin
Create a template, see below
Create a new note
Apply temple

Expected result

I would expect the properties to render in their nice little table

Actual result

properties are just shown as plain text

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: Darwin Kernel Version 22.4.0: Mon Mar 6 20:59:28 PST 2023; root:xnu-8796.101.5~3/RELEASE_ARM64_T6000 22.4.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Vileplume v1.0.2
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 2
1: Dataview v0.5.64
2: Templater v2.2.1

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

MacOs: 13.3.1
Debug info is from my normal vault, but I was able to reproduce this in the sandbox, as well as two different laptops.

Template Used

<%*
  let formattedDate = tp.date.now("dddd Do MMMM YYYY").toLowerCase().replace(/ /g, "_");
  let title = tp.file.title;
  if (title.startsWith("Untitled")) {
    title = await tp.system.prompt("Title");
  }
  let validTitle = title.replace(/ /g, "_") + "_" + formattedDate;

  // Rename the file with a valid title
  await tp.file.rename(validTitle);

  await tp.file.move("professional/meeting_notes/" + validTitle + ".md");
%>

Title: <% validTitle %>
Created: <% tp.date.now("dddd Do MMMM YYYY HH:mm") %>
Modified: <% tp.file.last_modified_date("dddd Do MMMM YYYY HH:mm") %>
Aliases: 
Tags:
Status:
# <% validTitle %>

### Notes
- 

### Action Items
- 

moved to help section

Same issue. Resolved in the interim by creating an “unnecessary” pre-existing tag in the template itself, and then the code for the template produced properties render correctly.

There needs to be the triple dash before and after for the properties to be recognised. And no space before the first set of dashes!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.