Obsidian crashes on Mac after update on every few seconds

Things I have tried

I have tried restarting Obsidian and installing older version.
I have tried disabling plugins.
I have tried deleting plugins.
I have tried deleting everything that obsidian created in ~/Library.
I don’t have themes.
Nothing helps, and I am using Obsidian for every little thing I am working on. Now I am completely blocked/

What I’m trying to do

Debug info after returning from 1.1.9 to 1.0

SYSTEM INFO:
Obsidian version: v1.0.0
Installer version: v1.0.0
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:19:52 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T6000 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 0

RECOMMENDATIONS:
none

Do you get any error messages in the console? That is open the Developers tools and select the Console pane. Does that show anything “useful”?

Are you able to open the sandbox vault and do some changes in there?

And finally, how does it crash? Like a full blown crash of the entire program, and you’ll have to restart it? Or like it hangs for quite some time, seemingly unresponsive? Or something else?

1 Like

I can’t see anything in the Console, because app crashes after few seconds and nothing really appears in the Console. Actually to be more precise, it’s not app that crashes but vault. I can open it for a few seconds and it returns me to the screen I see in the beginning.

This vault is being opened 10 seconds maximum and it returns to the home page.

That really sounds strange indeed. Are you able to copy over all of your files into a new fresh directory (especially one without the .obsidian folder), and see how that behaves?

This would of course require to re-add the plugins you’re using, but then again, that might also eventually show you the culprit of your issues.

The point I’m trying to make is that if you install the latest version with the latest installer, it should be pretty stable, and by copying the entire folder structure (except the .obsidian folder), you’ll get a very fresh start where there really shouldn’t be any issues opening the vault.

1 Like

Installed new Obsidian using new instalation:

And created completely new vault. Did not add any .md file in it. And the problem persists…
image

Another thing to try (if you haven’t yet): make a test user account in macOS System Settings/Preferences and try Obsidian in there using the Sandbox and then with a copy of your vault starting with no .obsidian, then no plugins, etc. I know it’ll take a few minutes, but creating and deleting user accounts in macOS is fairly painless.

I see you said you deleted Obsidian related items in ~/Library, but it’s worth trying in a new user account to see if it’s something specific to your main account.

1 Like

I can’t make another account since I am using company laptop. :pensive:

Have you restarted the computer?

That’s unfortunate.

Have you run Obsidian on this particular laptop in the past with no issues?

Maybe nothing, but I wonder if there is some corporate software or setup causing issues. On good terms with the IT staff? :sweat_smile:

is Obsidian an approved app by your corporate IT dept. If it is not, that could be the cause of the app crashing.

My synced vault started being unusable 3 days ago after updating my Mac Studio from macOS Ventura 13.1 to 13.2. Non-synced vaults are functioning normally.

Behavior
When I open up my primary vault synced through Obsidian’s sync service, I can see my last note and interact with it for a few seconds. Then, suddenly the entire window goes blank. I can resize it but can’t move it around - there’s no top bar but there are the 3 macOS colored circle buttons in the upper left corner. Closing and reopening the vault gives me another few seconds to interact with the note before the window goes blank again.

In the system console I found evidence that the Obsidian Helper (Renderer).app is crashing.

-------------------------------------
Translated Report (Full Report Below)
-------------------------------------

Process:               Obsidian Helper (Renderer) [68377]
Path:                  /Applications/Obsidian.app/Contents/Frameworks/Obsidian Helper (Renderer).app/Contents/MacOS/Obsidian Helper (Renderer)
Identifier:            md.obsidian.helper.Renderer
Version:               0.14.8
Code Type:             ARM-64 (Native)
Parent Process:        Obsidian [67924]
Responsible:           Obsidian [67924]
User ID:               501

Date/Time:             2023-01-26 12:38:52.6840 -0700
OS Version:            macOS 13.2 (22D49)
Report Version:        12
Anonymous UUID:        2D758FDE-B5F2-8D4E-269B-A203E6EAED78

Sleep/Wake UUID:       DF7620BE-1124-494D-A6D9-E1D32AE4C045

Time Awake Since Boot: 140000 seconds
Time Since Wake:       99849 seconds

System Integrity Protection: enabled

Crashed Thread:        68  DedicatedWorker thread

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000001, 0x000000011742b574

Termination Reason:    Namespace SIGNAL, Code 5 Trace/BPT trap: 5
Terminating Process:   exc handler [68377]

Thread 0:: CrRendererMain Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	       0x19b596050 mach_msg2_trap + 8
1   libsystem_kernel.dylib        	       0x19b5a811c mach_msg2_internal + 80
2   libsystem_kernel.dylib        	       0x19b59ec24 mach_msg_overwrite + 452
3   libsystem_kernel.dylib        	       0x19b5963cc mach_msg + 24
4   CoreFoundation                	       0x19b6b5bb0 __CFRunLoopServiceMachPort + 160
5   CoreFoundation                	       0x19b6b449c __CFRunLoopRun + 1232
6   CoreFoundation                	       0x19b6b3878 CFRunLoopRunSpecific + 612
7   Foundation                    	       0x19c5beab8 -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 212
8   Electron Framework            	       0x117498104 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 15855736
9   Electron Framework            	       0x117496e64 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 15850968
10  Electron Framework            	       0x11745eeec v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 15621728
11  Electron Framework            	       0x11742ea80 v8::internal::SetupIsolateDelegate::SetupHeap(v8::internal::Heap*) + 15423988
12  Electron Framework            	       0x11a3d9a98 node::CommonEnvironmentSetup::event_loop() const + 15963828
13  Electron Framework            	       0x114f57d08 v8::internal::compiler::BasicBlock::set_loop_header(v8::internal::compiler::BasicBlock*) + 14156
14  Electron Framework            	       0x114f58624 v8::internal::compiler::BasicBlock::set_loop_header(v8::internal::compiler::BasicBlock*) + 16488
15  Electron Framework            	       0x114f571b8 v8::internal::compiler::BasicBlock::set_loop_header(v8::internal::compiler::BasicBlock*) + 11260
16  Electron Framework            	       0x114f57684 v8::internal::compiler::BasicBlock::set_loop_header(v8::internal::compiler::BasicBlock*) + 12488
17  Electron Framework            	       0x114ce1688 ElectronMain + 128
18  Obsidian Helper (Renderer)    	       0x104b2499c 0x104b24000 + 2460
19  dyld                          	       0x19b2abe50 start + 2544

Looks like some crash in Electron

Obsidian 1.1.9 (bundle version 0.14.8)
macOS Ventura 13.2 (22D49)

I fixed it! Looks like my issue was caused by the Text Extractor plugin (version 0.4.0). Disabling this community plugin resolved the crashes for me.

Glad you solved your crash. But I assume “bundle” is a locale translation for “installer”. Make sure you download and reinstall Obsidian. You are quite out of date. The auto-installer can’t update the Electron version (or so). And in the release notes, it was said you had to download a fresh installer. You’re two major ones behind.