Obsidian Crashes Immediately On Opening On Mac OS

Things I have tried

Obsidian was working fine last night. This morning it crashes immediately on launching. It doesn’t get as far as opening the main application window. I see the Apple crash report window and I can click reopen or cancel. If I click re-open it happens again. The loop repeats indefinitely. Just before it crashed I had been toggling some plugins off that I no longer use and I think I might have enabled one or two others. I then changed my theme from Atom to Cybertron. Just as I went to change from light to dark theme after selecting Cybertron, the app crashed. I’ve not been able to open it since then. Silly me for making more than one change at a time I guess, but up to this point I’ve had no problems with the app crashing.

What I’m trying to do

I’ve tried looking for solutions in the forum

I’ve tried re-installing the application.

I’ve tried restoring an earlier version of the application from yesterday from a TimeMachine backup

I’ve tried installing a newly downloaded copy of the application. I noticed it is a newer version than the one I was running.

I have not yet tried deleting all of the relevant preferences files under the user/library folder to nuke the app and re-install.

Can anyone offer any suggestions. I really need to get back to work!

Many thanks in advance,



I’ve been trying a few things.

Deleted the folder Me/Library/Application Support/Obsidian/

This seems to allow Obsidian to open to the choose a vault window

I choose my existing notes folder which is in iCloud

Obsidian opens successfully.

At this point I deleted all of the community plugins.

I used Obsidian for a few minutes and created a new file

I closed Obsidian and tried to reopen it.

No luck. Back to instant crashing again.

I wondered if I could ‘turn the clock back’ to yesterday or ealier by restoring obsidian.app and the application support/obsidian folder from several days ago (when things were working fine)

I randomly selected a day about a week ago and restored the application and the library/application support/obsidian folder.

Restarted obsidian. So far so good.

Quit Obsidian and tried to restart it. Crashed again.

The bottom line is if I try to run Obsidian and it doesn’t find it’s library/application support/obsidian folder, then it launches via the vault selection window. I then select my existing vault folder and it opens and is useable. But if I then quit Obsidian and try to run it again, it will no longer run. It either does nothing or opens the MacOS crash reporting window.


  1. Make a full backup of your vault
  2. Delete the `.obsidian folder in your vault.

Thanks so much for that.

I totally forgot to backup first. Ooops!

Had to do a quick search for how to show hidden files in Mac OS as the only one I’d done that for previously was the users/library folder.

Shift-Command-Period reveals hidden files for anyone else who didn’t know.

Deleted the .obsidian folder.

Opened Obsidian.

All good.

I guess I’ll download the plugins I was using and unable them and I should be good to go.

Thanks again.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.