Obsidian Crashed and Won't Respond on Restarting

What I’m trying to do

I am trying to launch Obsidian with the same results as usual - it loads, full screen and shows me what I am currently working on.

Things I have tried

I was not on the current version, I was on version 1.4.5 running on KDE Plasma 5.27.7 with KDE Frameworks 5.109.0 with QT Version 5.15.10 on X11 on openSUSE Tumbleweed Linux 20230906. So I just now installed the latest version AppImage, 1.4.13.

This is the screen I get:

As you see, I get a white background with a “Start Here” section in the foreground. Nothing in the “Start Here” window responds to any mouse clicks. It is completely frozen.

I have the following plugins installed:

I moved the plugins directory out of the vault and restarted Obsidian. No change in behavior.

I moved community-plugins,json out of the vault and restarted Obsidian. No change in behavior.

Apparently there are active items in the white screen. If I click up in the right-hand corner where the close button would be, Obsidian does close.

After doing that, however, now when I restart Obsidian, there is only the white background. The “Start Here” window is now gone.

The next thing that happened was completely bizarre. Obsidian appears to have crashed the KDE desktop. A large blue band appeared on the desktop covering about two-thirds of the screen, then it began to flicker, then it began to fade out while nonetheless remaining as a pale band. I was forced to reboot the machine to regain control of the system.

I had a backup of the Vault on an external drive, so I backed up my notes to the drive again, and then restored the .obsidian directory over the top of the current one, and restarted Obsidian. No change in behavior - I still get a blank white screen with no “Start Here” window. I didn’t give it time to crash the desktop but closed it immediately.

It appears that something is major broken in Obsidian in both version 1.4.5 and 1.4.13 - or more likely that some system update has rendered Obsidian unworkable. This is very sad as I had high hopes for using Obsidian, but now I’m going to have to go with Joplin or CherryTree unless someone has an idea how to fix Obsidian.

What I will do next is remove Obsidian completely from the system, including removing the Vault, reinstall the 1.4.5 version and retest it. If it fails, I will remove it again, reinstall the 1.4.13 version and retest it. If it fails, it means Obsidian no longer works on openSUSE Tumbleweed.

OK, I removed Obsidian completely including the Vault, and reinstalled the 1.4.5 AppImage. This time when I start it, I get a completely black window as opposed to white window I had before. I closed it, removed it from the system, reinstalled the 1.4.13 version - same result. So I removed it as well.

I’m afraid Obsidian is done for on openSUSE Tumbleweed. Some system update appears to have removed Obsidian’s ability to function.

Update: Forget about the big blue band problem I reported. That appears to have been caused by another program I have installed - Stretchly, which is a timer to remind me to get up and walk for five minutes every thirty minutes. Apparently the last system update broke that program as well as Obsidian.

The other effects appear to remain a problem with Obsidian.

This is what I get for switching to a “rolling release” Linux distro: things break when the system is updated and the programs involved are not directly supported by openSUSE developers.

Well, well, good news! I uninstalled Obsidian and then today I went back and made sure the .config files were also deleted. I reinstalled the AppImage - and it’s working fine!

I have no idea what happened. I can only suspect that something in the .config files got corrupted somehow. When I restored the .obsidian files from the backup, I didn’t restore the .config files in my /home directory. Next time I’ll remember to try that. If anyone has the same issue, remember that there are hidden files in both the Vault and your home directory - make sure those are backed up when Obsidian is running okay.