Obsidian canvas card cannot be drag and drop after 1.1.15 update on Debian/Linux

After the update, I cannot drag and drop the cards in canvas in my Debian/Linux machine. Windows 10, and Fedora/Linux works fine.

3 Likes

we have no specific code pertaining any os, let alone among linux distribution.

I am having the same issue on Debian Linux after the update. I have disabled all community plugins, themes, and CSS Snippets to no resolution.

On Debian Linux, I am no longer able to:

  1. Drag and drop to move cards (the hand pointer animation grabs, but then does not move the card, and switches back to a standard pointer upon moving it)
  2. Reliably resize cards (this only intermittently works from the corners, and not at all from the sides of the card)
  3. Use middle mouse click to drag (middle mouse click instead creates a new card with unpredictable text, and only every other time clicked)
  4. Click and drag to select specific sections of the canvas at all (the shortcut ‘ctrl + a’ for the entire canvas is the only way to do so)

The workarounds I have been using are moving individual cards by clicking them and using the keyboard arrow keys, and shift clicking multiple cards to select them for any purpose.

All drag functionality seems to be gone with the 1.1.15 update on Debian Linux.

are you using X11, XWayland or Wayland?

Try X11 or X Wayland

As a diagnostic, I tried these tasks while running Ubuntu 22.04.

I logged in using both X and Wayland, and found that Canvas operated normally in both environments. I was able to create, drag, and resize cards without issue.

So this behavior might be related to the distro (Debian vs. Ubuntu), or perhaps the window manager, or perhaps the graphics driver of your distro. I also suggest trying switching from Wayland to X and see if that makes a difference.

I have the same problem with Chromebook Linux. Cannot drag and drop canvas cards. Everything else works OK and the mouse works fine in other Linux apps.

Hi, same here with chromeOS Version 112.0.5615.134 using obsidian AppImage 1.1.16.

u can if u have the two additional buttuon in your mouse like gaming mouse click at the up one and the left click and thn u can drag in ubuntu

Same problem on ubuntu 22.04LTS, with latest/all updates as of today. no luck Wayland or X. Can’t drag, grab handles, connect tiles.

Tried both appimage and snap versions of Obsidian 1.3.5

DOES work for me on Windows 10 machine that hosts one of the VM’s.

Any news? i found the same issue on centos.

obsidian version v.1.3.5

Hi @WhiteNoise,
Of course thats why electron is OS agnostic, otherwise it would be a horror to maintain :wink:
I just moved to Obsidian and have the same issue on Manjaro Linux inside a VM with i3wm as a window manager.
Do you have any tips how to troubleshoot that issue ?
Thanks in advance.

@Avery
I did some more testing and here are my findings:

Tested inside VM:

  • VMware Workstation 16.1.0 on Windows 10
  • Manjaro Linux Kernel 5.19.17-2
  • Resolution 1920x1080
  • i3wm & Gnome 44.1

WORKS:

  • connect boxes
  • move boxes with keyboard arrows
  • move connections with mouse
  • click and highlight
  • double click and change text
  • change size on corners only

does NOT work:

  • drag boxes with mouse
  • change size horizontal or vertical (mouse shows arrow)

@WhiteNoise please give us some information how to troubleshoot this issue.

Thanks in advance.
Best,
Cellcore

We have reports that Obsidian drag and drop does not work inside some virtual machine because it doesnt emulate well the mouse buttons. Try another virtual machine software.

@WhiteNoise I’ve tried other ones like virtual box, then different distributions and it is exactly the same.
I also have this problem on my old iPad mini, cannot drag in canvas.
I guess it is more a layer problem than a mouse click, because mouse clicks work for every single application I’m using in this VM since 5 years.
Also all other clicking in Obsidian work.

I’m convinced that the problem needs to be fixed in Obsidian.

If Obsidian would be open-source we could better troubleshoot and send a pull-request. :wink:

How can I open an issue or bugreport ?

regarding the virtual machine, we have already debug the issue and determined it was not emulating the buttons properly, I am not gonna take bug reports involving that.

Regarding the ipad mini, you can search/open a bug report in the appropriate section of the forum. Follow the bug report template, if you decided to open a new thread.

To avoid confusion, I am going to close this threads as it contains old reports about similar effects but from different causes.

@WhiteNoise sorry but emulating mouse buttons not properly is nonsense to me.
I even did tests with having mouse buttons triggered via keyboard.
If this would be the case then it does not work at all.
But it does on the corners and everything else is working.

Anyway, I see you are not interested in solving this issue, so be it.
Will have to look for alternatives as I do not have a different option.

Too bad, was a short time with Obsidian.

Thanks anyway.

I have the same issue on my Chromebook, but I understand from the conversation above that nothing is being made to solve it. I am not giving up on Obsidian because of this, I just signed up for Obsidian Sync (which I find expensive but helpful), and Canvas is not central to my use of the app. But having an issue dismissed like this is disappointing and makes me wonder if other issues will be dealt with this way. I use, as probably other people here, many apps in the Linux container in ChromeOS and none of them ever presented any weird mouse issues at all. If it is only Obsidian, well, you don’t need to be Sherlock Holmes to at least suspect Obsidian is the problem.

I am not here to fuel a flame war or something, but only to kindly insist that you guys at Obsdian please reconsider and try to help us and to fix this. It would make us all much more confident that Obsidian is the right choice to be our “second brains”!

Let me reiterate here that there are two cases we are aware of where drang and drop does not work.

Using Wayland, we are waiting for an upstream electron fix.
Virtual Machine, it depends on the way some VM software emulate mouse buttons not accurately (and we are not going to to anything about that).

If you have a different issue, open a new bug report and follow the BR template.