Obsidian Callout type suggestion not rendering?

Steps to reproduce

Execute command “Insert Callout” in any note. Delete the callout-type but keep the exclamation mark. Should look something like this:


Did you follow the troubleshooting guide? [Y]

Expected result

I have a very clear memory of there being a small scrollable list, showing what types of callouts you can enter into the brackets. When you clicked on one of the entries, that type of callout was automatically entered into the brackets.

Actual result

Nothing shows, and I have to rely on my human brain to remember the different sorts of callouts I can enter, and how they will look.


Obsidian version: v1.4.12
Installer version: v1.3.5
Operating system: Windows 10 Enterprise 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 17
Plugins enabled: 16
1: Obsidian Git v2.20.7
2: Mind Map v1.1.0
3: Calendar v1.5.10
4: Style Settings v1.0.6
5: Various Complements v8.4.1
6: Dataview v0.5.56
7: Emoji Toolbar v0.4.1
8: Obsidian Charts v3.7.2
9: Advanced Slides v1.20.0
10: Advanced Tables v0.19.1
11: Auto Note Mover v1.2.0
12: Export Image plugin v1.0.3
13: Webpage HTML Export v1.6.0
14: Buttons v0.4.19
15: Highlightr v1.2.2
16: Admonition v10.0.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I’ve never really understood if this functionality is native to Obsidian, or some sort of cross-feature between Admonitions callouts and the native Obsidian one. I might misremember, but in my mind, this little “suggestion-dropdown” for callouts have been showing even when I’ve disabled Admonition.

If this is me not understanding the interaction between core-plugins and community ones, consider this bug-report a feature-request, where Obsidian shows a callout-suggestion list when entering the callout type information here:


1 Like

I think it’s an Admonition feature :thinking: … but I could be wrong :innocent: .

From what I’ve just tested though I can say that:

I only get the a dropdown to select the “type” of callouts in a vault where I’ve installed Admonition (the dropdown list both “classical” callouts and custom ones).

In vaults where I didn’t install Admonition, the dropdown doesn’t show up (nor does it show up in the sandbox vault :blush: )

I have no idea if this will help or not, but you should download from the website and get the latest installer. 1.3.5 is a bit far behind.