Obsidian(appimage) random startup behaviour on hyprland arch linux

What I’m trying to do

I am trying to run Obsidian AppImage on my system, but often, it won’t even start up. and gets stuck on this message while the CPU consumption goes crazy.

Loading main app package /tmp/.mount_ObsidiPTECYD/resources/obsidian.asar

But the weird thing is, it usually runs smoothly after I launch Firefox (emphasis on “usually”).

Things I have tried

  • Have tried running with the options
    --ozone-platform=wayland --enable-features=UseOzonePlatform,WaylandWindowDecorations
  • Included these lines in my hyprland.conf
    exec-once=dbus-update-activation-environment --systemd WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
    exec-once =systemctl --user import-environment DISPLAY WAYLAND_DISPLAY XDG_CURRENT_DESKTOP

-Included this in my hyprland wrapper
export $(dbus-launch)

Could not edit the post for some reason, but this is the process that consumes a lot of CPU after obsidian does not startup properly

Xwayland :0 -rootless -core -terminate 1 0 -listenfd 28 -listenfd 29 -displayfd 1

When it does launch properly, I get this message if that is helpful.

2024-03-25 06:15:12 Loading main app package /tmp/.mount_Obsidi1MMk0m/resources/obsidian.asar
[4335:0325/121512.250753:ERROR:object_proxy.cc(577)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/portal/desktop: org.freedesktop.DBus.Error.InvalidArgs: No such interface “org.freedesktop.portal.FileChooser”
[4335:0325/121512.250831:ERROR:select_file_dialog_linux_portal.cc(285)] Failed to read portal version property
2024-03-25 06:15:12 Checking for update using Github
2024-03-25 06:15:13 Success.
2024-03-25 06:15:13 Latest version is 1.5.11
2024-03-25 06:15:13 App is up to date.

Also worth noting is that when obsidian launches properly, no Xwayland process runs in htop. It shows

/tmp.mount_ObsidiXZjNXx/obsidian --ozone-platform=wayland

along with many other related processes, but none of them show Xwayland

After installing xdg-desktop-portal-gtk, this error message does not show up. But the random start up behaviour still persists

So apparently, it had something to do with nouveau drivers, according to this reddit post I found: https://www.reddit.com/r/archlinux/comments/192qi86/abnormal_100_cpu_usage_on_xwayland/

Installing the proprietary Nvidia driver seems to have fixed my issue.
This is absurd as hell, I don’t even use my Nvidia card for my display, I use my intel igpu. But hey, as long as it works.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.