Obsidian app icon missing on Ubuntu 21.10

Hi, I installed recently obsidian on Ubuntu 21.10 like this:

$ wget https://github.com/obsidianmd/obsidian-releases/releases/download/v0.13.31/Obsidian-0.13.31.AppImage
$ chmod 755 Obsidian-0.13.31.AppImage
$ mv Obsidian-0.13.31.AppImage ~/bin/obsidian

So this was obsidian version 0.13.31 I installed.

When I run obsidian the icon shown in the launcher and window switcher is an icon with interlocking gears (probably a default icon that is shown if the apps icon is missing)
Expected icon:


Actual icon:
icon

check with the latest version.

Same problem with Obsidian-0.14.2.AppImage

What desktop manager are you using?

I am using ubuntu:GNOME according to $XDG_CURRENT_DESKTOP environment variable

what app launcher are you using?

I run the obsidian app image from the (bash) shell:

$ chmod 755 Obsidian-0.13.31.AppImage
$ mv Obsidian-0.13.31.AppImage ~/bin/obsidian
$ export PATH=$PATH:~/bin
$ obsidian # <- This runs the app from the shell

Check your obsidian.desktop file. I use Garuda, and it is in ~/.local/share/applications. It should have an Icon=path/to/icon/image in the file. If it doesn’t, you can add it to the file. I have attached mine as a .md file for reference.
Obsidian Desktop File.md (1.3 KB)
Also, I use appimagelauncher rather than the shell.

Hi jwl! I seem to be missing the .desktop file itself

$ ls ~/.local/share/applications/obsidian*
ls: cannot access '/home/hakon/.local/share/applications/obsidian*': No such file or directory

I never had luck with icons in Appimages, I always needed to specify them manually in the desktop file.

I don’t think this is a bug.

Try AppImageKit to list the contents of your appimage. It should show an obsidian.desktop or obsidian.png as one of the files.

Yes it does show all the files:

$ appimagetool --list obsidian | grep obsidian
appimagetool, continuous build (commit 8bbf694), build <local dev build> built on 2020-12-31 11:48:33 UTC
obsidian
obsidian.desktop
obsidian.png
resources/obsidian.asar
usr/share/icons/hicolor/128x128/apps/obsidian.png
usr/share/icons/hicolor/16x16/apps/obsidian.png
usr/share/icons/hicolor/256x256/apps/obsidian.png
usr/share/icons/hicolor/32x32/apps/obsidian.png
usr/share/icons/hicolor/48x48/apps/obsidian.png
usr/share/icons/hicolor/512x512/apps/obsidian.png
usr/share/icons/hicolor/64x64/apps/obsidian.png

I wonder why the icons show as usr/share/icons... ? Does this mean that it will install them there when running obsidian ? In that case I would need to run obsidian with sudo since I (the username hakon) does not have write access to /usr folder…

Is there a way I can extract those icons from the appimage file? Then I can try to install them manually. I should then be able to create a desktop file with a desktop entry that points to the icons. I think saving this .desktop file as ~/.local/share/applications/obsidian.desktop may then work?

I did some more investigations and think I found the solution. For some reason the icons embedded in the appimage is not embedded into the system if you run the appimage directly from the terminal. To get the icons integrated into the system you can use appimaged from GitHub - probonopd/go-appimage: Go implementation of AppImage tools. Still experimental or use AppImageLauncher, see kde - Registering AppImage Files as a desktop app - Ask Ubuntu. I tried the latter, see Install on Ubuntu or Debian · TheAssassin/AppImageLauncher Wiki · GitHub

$ sudo apt install software-properties-common
$ sudo add-apt-repository ppa:appimagelauncher-team/stable
$ sudo apt update
$ sudo apt install appimagelauncher
$ AppImageLauncher ~/bin/obsidian

Now the launcher first presents the following dialog:
appimg1

if you press the “ok” button, a new dialog appears:

appimg2

Then press “Integrate and run” to finish the installation.

If you now go to the Ubuntu launcher and click the “Show applications” icon. Then type “obsi” into the search bar. The obsidian icon should appear and you can click it to run obsidian.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.