Obsidian and custom unicode characters

What I’m trying to do

Recently, for resons i will not name (for the sake of saving time), i tried to paste a few custom/personal/private unicode characters into obsidian note editor, to see if they’ll appear properly, like in the normal notes app, and if i can use them in my notes
Turns out, obsidian doesnt show them at all , replacing them with already existing standart unicode characters, or questionmarks
Is there any plugin/theme that can fix this?
Really, it’s not inportant, and i can go by with just screenshotting them from a notes app, but it would be a bit more convinient to have it directly in obsidian app

Things I have tried

-Searching for possible settings to turn this off - zero results
-Trying to change a font - no results
-Pasting characters into the notes app, to see if its issue on my side-works just fine in the notes
-Googling - stumbled over this forum, thinking it might help
-Googling, but add “reddit” at the end of it - nothing of help was found
-Placing the symbols in a “codeblock” - turned them into a bunch of question marks

Extra info:I dont really need to extract or share my notes to the other apps, so “recoverability” of my notes doesnt really matter,if that helps in any way to find a solution

They need to be supported in the font you’re using for them to appear.

That’s about all the response we can give without actually knowing which characters, or how you’ve defined them as custom character, and what you’ve done with them in your current font.

Alternatively you could import them as images, possibly.

They are made with windows built-in “private character editor” app, and are, (judging by the settings,) supposed to have support for all the fonts that are insalled on my pc(and only on my pc)
Obsidian , or some internal pc, stuff just replaces them with similar looking already existing unicode characters, that are not “user-generated”
And regarding the idea of pasting them as images-already tried it, it works fine, but it would be really nice to actually see them in an an app, to be able to edit/remove them right there (that’s why it’s just a convinience issue, and nothing of serious value)

Issue solved,(or workaround found) browsed through a plugin page, found a plugin that can insert icons into the text

(I’m really sorry,I should’ve searched more carefully , before going here)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.