Obsidian 1.0.0 inoperative on Linux Mint 20.3

Steps to reproduce

Using the Software Manager (the package manager for Mint) I upgraded Obsidian to the latest version, 1.0.0. After startup, I tried to click on the Settings icon, and nothing happened other than the Settings icon changing color shade. I believe it thought the pop-up dialogue was rendered (it wasn’t), because the currently-open notes were unresponsive, as well as the plugins sidebar. I could still click on the “open vault” icon which rendered a black box on the screen, which should have been a window. I could grab the top of this black box and move it around the screen, and the box would close if I clicked on the top-right corner, so the controls are there but invisible; the box is blank. After closing the black box, I am still in the weird mode where it thinks the Setting dialogue is up, but it isn’t. I haven’t found a way out of this mode, so the only thing I could do is close Obsidian.

I tried uninstalling Obsidian and installing fresh and got the same result. I tried forgoing the package manager and installing the flatpak from the Obsidian downloads page, same result.
On my last attempt, when I restarted Obsidian, it did not open the previous vault but instead brought up the vault selection dialogue, along with the new editor mode selection. I made a selection and was able to open a vault. I then opened the preferences, which opened correctly on the Editor options. When I clicked on the Appearance options, it froze again, and I could no longer close the Settings window. I was only able to close all of Obsidian. It seems like something foundational isn’t behaving.

Expected result

Work as normal.

Actual result

Not working at all, seems to be something wrong with how things are rendered.


  • Operating system: Linux Mint 20.3

  • Debug info:
    Obsidian version: v1.0.0
    Installer version: v1.0.0
    Operating system: #144-Ubuntu SMP Tue Sep 20 11:00:04 UTC 2022 5.4.0-128-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

have a backup, try to move the .obsidian folder out of your vault and see if it starts.

For the last-used vault (The one it would open upon startup) I moved the .obsidian directory out of the vault. Upon startup it opens the vault fresh, as expected. But Settings still hangs. This is going to sound weird, but I’ll describe what I see. Once the settings box hangs, I tried to scroll the settings list inside of it, and the entire Settings window would flash (going away and coming back) consistent with my scrolling. It was as if the scroll was tied to the Settings icon on the tool bar, and interpreting it as if I was pressing the Settings icon over and over again.
This is also not consistent. I just restarted Obsidian and I was able to open settings, scroll the Editor settings list, and switch to the Appearance settings. I closed the window, opened settings again, and it went haywire.

I should also add that there is nothing special about the Mint installation. No extra drivers, it’s just a vanilla install. It only has three additional products installed:

  • PlantUML
  • GraphViz
  • Obsidian

Perhaps also important to note (since it may be graphics related) that it’s a VM under VirtualBox 6.1.38 (latest release for Mac.)

I don’t think there’s much we can do. You can try disabling hardware acceleration in settings>about

Turning off hardware acceleration did mitigate the problem. Odd, because the VM does support acceleration, and is used. Must be something new in the v1.0.0 stack. Thanks for the suggestion.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.