Notes with content from previous versions of Obsidian show as blank in 1.0

I have notes that were created in pre-1.0 obsidian. When I open those notes on a new laptop, running Obsidian 1.0 Mac, the content is not visible. It only shows the note name. When I open the exact same note in a markdown editor on the same device or in an older version of obsidian on a different Mac the content displays normally.

I’ve tried using the default theme, and other themes but none of the note content is displaying and I’m not aware of a configuration setting that would affect this behavior.

It case it matters, the vault/notes are stored on Dropbox

try default theme, no snippets, restricted mode. restart obsidian
It’s likely a theme, snippet or plugin problem.

I’m using the default theme, no snippets are installed/enabled, and I’ve disabled all plugins including core plugins. I’ve also restarted Obsidian after disabling all plugins. The problem continues.

What I see in 1.0:

What I see in V0.15.9

Can someone point us to how to install previous version. This is a disaster. I use this for work and I can’t do my job.

1 Like

Close and reopen obsidian.

Can you post a screenshot of what you see?

We do not recommend going back. Update your theme, or better use the default one. Make sure you have no snippets enabled. Update your plugins. Restart Obsidian.

ok, if you open that note outside of obsidian, is the content there?

Are you using the dropbox option to not keep all the files locally?

  1. back up your notes
  2. use something like sandboxie to isolate things if you want to play it safe
  3. prevent internet access
  4. “install” obsidian sandboxed
  5. turn off automatic updates in Options > About in Obsidian
  6. move your notes in there
  7. pretend that being told to just deal with 1.0 isn’t obscene

Why in the world would downgrading not be a perfectly legitimate solution?

Yes, all the content is present - though rendered differently - when opened in Typora. Here is the same note referenced above when viewed in Typora

Also, I should note that Core plugins keep re-enabling themselves when I restart Obsidian 1.0. So when disabling all core plugins, quitting Obsidian, and restarting Obsidian the plugins are running on restart.

Few things:

  1. I seem unable to uninstall plugins - hitting ‘Uninstall’ doesn’t do anything. Can I simply delete the folder ?
  2. How disable snippets ?
  3. My error - everytime I just open a file - is "Templater Error: Template parsing error, aborting, etc…
    Thank you for your help ! I’m only so frustrated b/c I like obsidian so much…

Make sure the dropbox is keeping all files locally. Also are you sure you are opening the same file?

Can you post a screen recording of your vault?

DO you have the problem described in this thread or another?

OK - having Dropbox copy the files locally (I.e., make files available offline) resolved the issue. Thank you for your help.

Are you up to date with the latest 0.15.9 or 1.0.0 installer version?

I suggest posting the results of “Show Debug Info”

(Oops, just saw your “resolved” reply. Too slow, me.)

Thank you for the fast response - and the quick solution. Now that I can see data, I love the new UI look. Very well done.

Being up to date is a recommendation.

You’re perfectly free to downgrade or disable auto-updates, but you can’t really expect free community support if things go wrong as the app gets out of date. The volunteer community can’t be expected to support all past versions, or permutations of bugs from people doing technical workarounds.

I see notes - I just can’t use Templater which is the basis of everything I do in obsidian…

ok, so. Have you tried updating it along with the other plugins?
Community Plugins > Check for updates and then Update.

Restart Obsidian.
If it still doesn’t work, I suggest you open a specific thread about the problem and maybe open a BR directly to templater github repo.

yes…i have

For the error you are getting, it looks like you have an error in your templates. Maybe you just need to fix that error. I don’t suggest you delete plugins or take drastic actions. This is a specific problem with a specific plugin. Open a ticket to templater github and attach your template and the error you are getting.

1 Like