Note won't link to a particular block in another document

I am trying to link a short zettel note to a block in a larger literature note.

  1. I type [] and locate the target literature note, then entering ^ to scroll through the text. There is, as you know, a limit to the amount of the target literature note’s text visible in the scrolling view so I typically at this point type in the page number — in this case 230. This always works. The view always snaps to the correct location and I click on the block and the link is made.

In this case however I’m typing in 230 (the block / page number) and it won’t find it. It snaps to a different block. It works if I input 239 or 231.

Has anyone any idea what is going on?

I changed the initial number (page) on the top of the block from 230 to 231 and then it worked. For some reason it refused to see 230 but once I changed it to 231 it worked. So I did that and then changed the target note text back to 230 and it’s fine now…spooky!



Can you please post a screen recording of this happening in the sandbox vault and attach a copy of the note that causes this?