Not able to paste images from clipboard to notes - MacOS

What I’m trying to do

I am not able to paste images I have copied in the clipboard inside obsidian. I am able to paste images, which I already downloaded via finder and also have an extra attachments folder assigned, but I want to fast paste screenshots.
I am on MacOS - MacBook.

Things I have tried

I have my vault inside iCloud and plug-ins installed HOWEVER I already tried moving my vault and disabled the plugins but nothing worked.

Have you tried to take a screenshot to the clipboard instead?
Keyboard shortcut should be shift+cmd+4 . Otherwise open System Preferences > Keyboard > Shortcuts

Can you post your “Show Debug Info”? Or make sure you’ve been through all the other trouble-shooting steps, like updating your installer, plugins, themes, etc.

Hey, taking a screen shot via macOS doesn’t work. Also trying to bind a new hotkey through the settings.

Hey, I tried to reinstall and disable all plugins. However I think I have a clue: I got an attachments folder as mentioned in my vault. both of them are inside my iCloud. It is also not possible for me to paste images on my iPhone inside Obsidian. After setting the file location of my attachments to “vault folder” I can paste images like I want to! Still I want to keep my vault synced through iCloud - do you have any ideas how I can keep this setup, is someone experiencing same issues? (I already checked spelling mistakes of folder)

After putting a copy of my vault onto my MacBook and trying pasting there, I experienced the same issue of not being able to paste pictures. This would speak against iCloud being the problem…

What is “Media:Attachments”? Do you have a folder with a colon in the name? That is probably the problem. Remove the colon and I bet it will start working.

I can’t even make a folder with a colon in the name on MacOS, so I’m not sure how you ended up with that.

Hey rigmarole, you solved the problem for me!

In my Vault there was a folder called Media/Attachments, I was also not able to use colons in MacOS as a Folder name. However inside Obsidian’s settings in the drop-down menu it is written with a collon instead of the slash:

After changing the name of the folder to anything without the slash symbol I was able to paste again - seems like its a random bug and nothing severe with iCloud :)))
thanks for the clue!

The reason colons in filenames can cause problems is MacOS used to use colon as the folder separator instead of slash, and it still has some compatibility stuff built in to deal with that.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.