Not able to create table using pure markup

What I’m trying to do

I am trying to create a table using pure markdown (i.e not using “Advanced tables” or other plugins")

Things I have tried

To create the table, i try to create it using the pipe character i.e “|” - See screenshot below.

The above does not result in a table being created. When i switch to reading view, i see the same text.

The only way i am able to create a table is that after entering the above text to create a table, i have to insert a new row using the Advanced table plugin shown below - i.e if i select new row/column, the markup text then switches to a table.


Note - This was not an issue previously, i only noticed it after a recent release which included some changes to how tables work.

Note - there is a similar topic which suggested the following options which i have tried all of them but nothing resolved it.

  • There must be a space between the text
  • There must be a space or empty line before the start of the table
  • Try pressing Enter after each row.

None of the above solved the issue.

You need a spacer line between the title and content

So like

| Heading 1 | Heading 2 | Heading 3 |
| ---------- | ---------- | ----------- |
| content    | content     | content      |

Within that spacer bar (don’t know if that’s the technical term) you can include colons to indicate the text alignment.
Like this ----:, this :----, or this :----:

Colon on right Colon on Left Double Colons
:slight_smile: :slight_smile: :slight_smile:

The second table row is called delimiter row which uses at least one dash. Colons : are used for whole column text alignment. You can use colons normally elsewhere thus delimiter row has its purpose. Pipes can be hard to write depending on your keyboard layout so you could use // to replace for pipes (see auto text replacements in mac).

Ok using the spacer line resolves the problem - thanks :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.